summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-12-22 09:20:37 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-12-23 20:51:53 +0100
commit6f8352228f4713b108434ee538bc8e8d1bef0617 (patch)
tree23f071c570374fb8b6e71538cfa381af2d620f2d /net-analyzer
parentnet-analyzer/sec: fix LICENSE (diff)
downloadgentoo-6f8352228f4713b108434ee538bc8e8d1bef0617.tar.gz
gentoo-6f8352228f4713b108434ee538bc8e8d1bef0617.tar.bz2
gentoo-6f8352228f4713b108434ee538bc8e8d1bef0617.zip
net-analyzer/sflowtool: add 6.06
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/39818 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sflowtool/Manifest1
-rw-r--r--net-analyzer/sflowtool/sflowtool-6.06.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/sflowtool/Manifest b/net-analyzer/sflowtool/Manifest
index 6f5c278eb1ff..bbbc01a03cd6 100644
--- a/net-analyzer/sflowtool/Manifest
+++ b/net-analyzer/sflowtool/Manifest
@@ -1 +1,2 @@
DIST sflowtool-5.06.tar.gz 78044 BLAKE2B db4a14d3e94660c803399f99b486bc04579b8dacf4e01f484ebeb31cbeec0ad279efdbd85b5a242a4dd9016e36428992344af50275dfd15c89b3337351d5fdb0 SHA512 365922e09544928bbf5893c04e05bc5b3d632290804711cc248d6bbd52c8ed30646bb9bdfd7b231a357f88bd5592473b95edff6ab3b50121809f909b4b65c7a2
+DIST sflowtool-6.06.tar.gz 82125 BLAKE2B c817742f196fc90f273c3fba53475a2e345d24e116ace4015adfb2d06e7737a04db307c53c25241df4d4ac4a4f5bb5fcf652429142e6d628edae6125352270ee SHA512 68acfc5da9ee52b95c59d40986d267546f69e6d286c3a3cf35967d89cd970c2e8f8d32d6eb3f985a6bb48bd695ebed3f42559dcdc993b4fa8d3b904f6f9d756a
diff --git a/net-analyzer/sflowtool/sflowtool-6.06.ebuild b/net-analyzer/sflowtool/sflowtool-6.06.ebuild
new file mode 100644
index 000000000000..4fbad47c6fac
--- /dev/null
+++ b/net-analyzer/sflowtool/sflowtool-6.06.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Utility for collecting and processing sFlow data"
+HOMEPAGE="
+ https://inmon.com/technology/sflowTools.php
+ https://github.com/sflow/sflowtool
+"
+SRC_URI="https://github.com/sflow/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="inmon-sflow"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -DSPOOFSOURCE
+ use debug && append-cppflags -DDEBUG
+
+ default
+}
+
+src_install() {
+ default
+ dobin scripts/sflowenable
+}