summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:55:50 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:55 +0100
commit986a4c519bfbbed4db30fc3db8f6f032f8dd32a2 (patch)
tree649cb53899ba131b17a5eac009443d4142aed9aa /net-analyzer
parentnet-analyzer/fail2ban: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-986a4c519bfbbed4db30fc3db8f6f032f8dd32a2.tar.gz
gentoo-986a4c519bfbbed4db30fc3db8f6f032f8dd32a2.tar.bz2
gentoo-986a4c519bfbbed4db30fc3db8f6f032f8dd32a2.zip
net-analyzer/prelude-correlator: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/prelude-correlator/prelude-correlator-5.2.0.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-analyzer/prelude-correlator/prelude-correlator-5.2.0.ebuild b/net-analyzer/prelude-correlator/prelude-correlator-5.2.0.ebuild
index 62f46b3c3ace..359b4c7a6bfd 100644
--- a/net-analyzer/prelude-correlator/prelude-correlator-5.2.0.ebuild
+++ b/net-analyzer/prelude-correlator/prelude-correlator-5.2.0.ebuild
@@ -35,3 +35,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}.initd" "${PN}"
}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}