summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-07-24 19:48:09 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-26 22:15:55 +0300
commitc672522b797b1667105f64fdbb136039c87a9a99 (patch)
tree90d8bf5040dbf9c47e54271652261875c5a7f9ef /net-analyzer
parentdev-db/litecli: add 1.11.1 (diff)
downloadgentoo-c672522b797b1667105f64fdbb136039c87a9a99.tar.gz
gentoo-c672522b797b1667105f64fdbb136039c87a9a99.tar.bz2
gentoo-c672522b797b1667105f64fdbb136039c87a9a99.zip
net-analyzer/tcping: add 2.1.0
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37705 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcping/Manifest1
-rw-r--r--net-analyzer/tcping/tcping-2.1.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/tcping/Manifest b/net-analyzer/tcping/Manifest
index 6efff5e7cf56..2da9cb762504 100644
--- a/net-analyzer/tcping/Manifest
+++ b/net-analyzer/tcping/Manifest
@@ -1 +1,2 @@
DIST tcping-1.3.6.tar.gz 3329 BLAKE2B cd69e259d930532810bf3b19d22db981d644051e472d6356e442df2074ebd6fe675b62540190f465127bdcd0c248f329b3e5c167a6c4408acfef029297b5e181 SHA512 74c65f292d6521dfbf8784ae9e1988a12ad224c81f6575ada1cae55b079cf9c13707be52cb9147abe02c8787ebbedb0d9fca1f2c27fb57c32eea5817c7042992
+DIST tcping-2.1.0.tar.gz 6532 BLAKE2B 8d154b36480180ae6fd2a644b98ee0ed569e1d7491a2fe5a5ced9a3ad2470d8a34cbbed499ba93661816075617cdb00f83c1469866f3bf63871fbbc6f67168ca SHA512 d39c30390a7ab7a345f3b8fc2731afa817b104460a65ad47f1e535d1a5242eed7eb5b8c416b898dd4eedc87cf16af7bbb0630c63731b12513fa4f95eb9dfaed0
diff --git a/net-analyzer/tcping/tcping-2.1.0.ebuild b/net-analyzer/tcping/tcping-2.1.0.ebuild
new file mode 100644
index 000000000000..b7f426393c4b
--- /dev/null
+++ b/net-analyzer/tcping/tcping-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Check if a desired port is reachable via TCP"
+HOMEPAGE="https://github.com/mkirchner/tcping"
+SRC_URI="https://github.com/mkirchner/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -e '/^CC=/s:=:?=:' \
+ -e '/^CCFLAGS/s:=:+=:' \
+ -e 's/$(CCFLAGS)/$(CCFLAGS) $(LDFLAGS)/' \
+ -i Makefile || die
+ tc-export CC
+ export CCFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin tcping
+ dodoc README
+}