summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2023-02-07 19:24:03 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-02-09 15:31:13 +0200
commitcb6f659563b4948d47bd7520020d739d74bd0a44 (patch)
tree9c07b48f33839bece1fbcdce11371af386446d90 /net-analyzer
parentnet-analyzer/linkchecker: drop 10.0.1 (diff)
downloadgentoo-cb6f659563b4948d47bd7520020d739d74bd0a44.tar.gz
gentoo-cb6f659563b4948d47bd7520020d739d74bd0a44.tar.bz2
gentoo-cb6f659563b4948d47bd7520020d739d74bd0a44.zip
net-analyzer/linkchecker: drop live
Signed-off-by: Chris Mayo <aklhfex@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/linkchecker/linkchecker-9999.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/net-analyzer/linkchecker/linkchecker-9999.ebuild b/net-analyzer/linkchecker/linkchecker-9999.ebuild
deleted file mode 100644
index c473050a7913..000000000000
--- a/net-analyzer/linkchecker/linkchecker-9999.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-PYTHON_REQ_USE="sqlite?"
-
-inherit bash-completion-r1 distutils-r1 optfeature
-
-DESCRIPTION="Check websites for broken links"
-HOMEPAGE="https://github.com/linkcheck/linkchecker"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/linkcheck/linkchecker.git"
- inherit git-r3
-else
- SRC_URI=""
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="sqlite"
-# requires libs not present in portage yet
-RESTRICT="test"
-
-RDEPEND="
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/dnspython[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-9.3-bash-completion.patch"
-)
-
-DOCS=(
- doc/changelog.txt
- doc/upgrading.txt
-)
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- newbashcomp config/linkchecker-completion ${PN}
-}
-
-pkg_postinst() {
- optfeature "bash-completion support" dev-python/argcomplete[${PYTHON_USEDEP}]
- optfeature "Virus scanning" app-antivirus/clamav
- optfeature "GNOME proxy settings support" dev-python/pygobject[${PYTHON_USEDEP}]
-}