summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-21 22:23:23 +0100
committerSam James <sam@gentoo.org>2022-06-21 23:00:20 +0100
commit0052d62f6f3c2bb45fca98fb1ea546b4ae67ccec (patch)
treeb5a05c383e4ecbe092e88bafda51d1f9624d712e /net-dns
parentnet-dns/libidn: add gitlab upstream metadata (diff)
downloadgentoo-0052d62f6f3c2bb45fca98fb1ea546b4ae67ccec.tar.gz
gentoo-0052d62f6f3c2bb45fca98fb1ea546b4ae67ccec.tar.bz2
gentoo-0052d62f6f3c2bb45fca98fb1ea546b4ae67ccec.zip
net-dns/libidn: add 1.40
Drops mono and java support because not worth the maintenance hassle. mono-env.eclass doesn't support EAPI 8 and the Java build broke for some reason (think it was trivial, but...) Can restore if someone really needs them. Bug: https://bugs.gentoo.org/723272 Closes: https://bugs.gentoo.org/804825 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/libidn/Manifest2
-rw-r--r--net-dns/libidn/libidn-1.40.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/net-dns/libidn/Manifest b/net-dns/libidn/Manifest
index 982af456c312..f24a1f8c0c49 100644
--- a/net-dns/libidn/Manifest
+++ b/net-dns/libidn/Manifest
@@ -1,2 +1,4 @@
DIST libidn-1.38.tar.gz 2681263 BLAKE2B 92059e87554338a3565ee4b517fa1ba7bd3e9d57d8be7d71aee377220f50b597e529469c6ddc7c9e7c25b9e83c76f652457256dd32249c3e1cd97df8867723a1 SHA512 5e59b2263fde44d1463b47b516347b17a4e3e3696ebba66ab5fe464d567e2ec81f769fa7cf72ed51cfb501e32221813bb375373713a47e2f599fc6122850e419
DIST libidn-1.38.tar.gz.sig 488 BLAKE2B 3a5a5f3d79f2f01019d71e2b20b7daf264c71ed21ec922733c03ed42e0acd0bb6c2758ca7095b7fc52025d01c784eb539e53408ae663ac2bcdcc8e92ba11f342 SHA512 9caf0f9633f607861e94d6efe30383181db67e6fb437903b6c1ff1758363824afc1b01458f845d2bf11c8f2ec01708ba98da54a43a6e2429978caa0f41166ffe
+DIST libidn-1.40.tar.gz 2675320 BLAKE2B 04ebf5d751c6bc94ff228dceee5cb1ba173f571b23ea13d2066f5e93a24743f520f47692eaee3b52d8e049546a0527c8a88d373ac066deb2f258b2848117a021 SHA512 6588454c0a6153b76090057c0f3b97ef6cd78b3d7c84dd27cb9537556b7f6d2b4048485c3b82e33e9fb3c9b8d308c0899676ea92f92cf201a6454bd9af781f96
+DIST libidn-1.40.tar.gz.sig 228 BLAKE2B c62afa7e4f6a8cc408ddf44015d5b811b3eb11385963a74e40d68214b50d818ba9844fbc759cd97581d2b312d859149d792543a882c3ebe0b3e8d251d1d7cc86 SHA512 4fa8cb0da6fc4ced4575f5d6a98fcf273ace7a2f81e2c5eb699a1afb15cb282661bfc66cfc1181c7037011b1948ebadcd7e8ee6cea1c6b33a3ac35165744a904
diff --git a/net-dns/libidn/libidn-1.40.ebuild b/net-dns/libidn/libidn-1.40.ebuild
new file mode 100644
index 000000000000..9458f6683f2b
--- /dev/null
+++ b/net-dns/libidn/libidn-1.40.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libidn.asc
+inherit elisp-common libtool multilib-minimal verify-sig
+
+DESCRIPTION="Internationalized Domain Names (IDN) implementation"
+HOMEPAGE="https://www.gnu.org/software/libidn/"
+SRC_URI="mirror://gnu/libidn/${P}.tar.gz
+ verify-sig? ( mirror://gnu/libidn/${P}.tar.gz.sig )"
+
+LICENSE="GPL-2 GPL-3 LGPL-3"
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc emacs nls"
+
+DEPEND="nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}"
+BDEPEND="emacs? ( >=app-editors/emacs-23.1:* )
+ nls? ( >=sys-devel/gettext-0.17 )
+ verify-sig? ( >=sec-keys/openpgp-keys-libidn-20220621 )"
+
+DOCS=( AUTHORS ChangeLog FAQ NEWS README THANKS )
+
+src_prepare() {
+ default
+
+ # For Solaris shared objects
+ elibtoolize
+}
+
+multilib_src_configure() {
+ # -fanalyzer substantially slows down the build and isn't useful for
+ # us. It's useful for upstream as it's static analysis, but it's not
+ # useful when just getting something built.
+ export gl_cv_warn_c__fanalyzer=no
+
+ local args=(
+ $(use_enable nls)
+ --disable-csharp
+ --disable-java
+ --disable-valgrind-tests
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}"
+ --with-packager-bug-reports="https://bugs.gentoo.org"
+ --with-packager-version="r${PR}"
+ --with-packager="Gentoo Linux"
+ )
+
+ ECONF_SOURCE="${S}" econf "${args[@]}"
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi; then
+ use emacs && elisp-compile "${S}"/src/*.el
+ fi
+}
+
+multilib_src_test() {
+ # Only run libidn specific tests and not gnulib tests (bug #539356)
+ emake -C tests check
+}
+
+multilib_src_install_all() {
+ if use emacs; then
+ # *.el are installed by the build system
+ elisp-install ${PN} "${S}"/src/*.elc
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+ else
+ rm -r "${ED}"/usr/share/emacs || die
+ fi
+
+ einstalldocs
+
+ use doc && dodoc -r doc/reference/html
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}