summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-11-06 12:16:44 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-11-06 12:16:44 +0100
commitad1a91a87789c76e0564d7da6baa88186e5cce0e (patch)
treec5e515bf5ed8daef3989a712c04aa2e206178df2 /net-ftp
parentsci-libs/scikit-image: add 0.22.0 (diff)
downloadgentoo-ad1a91a87789c76e0564d7da6baa88186e5cce0e.tar.gz
gentoo-ad1a91a87789c76e0564d7da6baa88186e5cce0e.tar.bz2
gentoo-ad1a91a87789c76e0564d7da6baa88186e5cce0e.zip
net-ftp/filezilla: add 3.66.1
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.66.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index 4bb57b311cd3..b502419d11af 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -1,2 +1,3 @@
DIST FileZilla_3.65.0_src.tar.xz 4055316 BLAKE2B 4f702de98baeddda76ba0f3eaa5a06b49e863785980c8a57b84fdf7d3ce49f40b0ae123806c5e76693f19424696daf9ee044813c60bc4ec4216d19f2eccacf48 SHA512 8fb2862eaa7aa4331a095e67335f8e2805936f4866c49f617bdfb819638ecdcbc94e15e8810d90c2eb56e04f0100b8deeb5b691a45012896963ea4ba59644d04
DIST FileZilla_3.66.0_src.tar.xz 4055872 BLAKE2B b6a66b156d14d012098d63e4bc91bbe3ed9d3b271774f4a169b2c240da67556f52a57b022852942ff3ab068ff4cfbfcc94f2b9681ad9c7cb7dadc362dc22afc0 SHA512 8772987ed0772cb23f2ff15f7a9d8b24d9086b6f24d83c9aa430cbbb7c3e3b8fe209116ae590836e708db1a985539d214cd219413485823a7cc031462e20326d
+DIST FileZilla_3.66.1_src.tar.xz 4056092 BLAKE2B 43d7be5a6a1d3abc68e8d0e101b796fbe4183acbad2d9485db6ca8a027c82abdf3fba0887c31c911179205b7a774833da1a66d20f7bf12a2caa5e56772a2c1fd SHA512 2c038bb179e29f96062ee1f871571ed2669689af470ab86ecf9eef8e76ff90c44dc9940506c6ab5b100453811e13546c6c25eb6389b0f7a7e2c61c21c36fdb34
diff --git a/net-ftp/filezilla/filezilla-3.66.1.ebuild b/net-ftp/filezilla/filezilla-3.66.1.ebuild
new file mode 100644
index 000000000000..cb61885b28b4
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.66.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+
+inherit autotools flag-o-matic wxwidgets xdg
+
+MY_PV="${PV/_/-}"
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.xz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="cpu_flags_x86_sse2 dbus nls test"
+RESTRICT="!test? ( test )"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND="
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/boost-1.76.0:=
+ >=dev-libs/libfilezilla-0.45.0:=
+ >=dev-libs/pugixml-1.7
+ >=net-libs/gnutls-3.5.7
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cppunit-1.13.0 )"
+BDEPEND="
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.22.1-debug.patch
+ "${FILESDIR}"/${PN}-3.47.0-metainfo.patch
+ "${FILESDIR}"/${PN}-3.47.0-disable-shellext_conf.patch
+ "${FILESDIR}"/${PN}-3.52.2-slibtool.patch
+ "${FILESDIR}"/${PN}-3.60.1-desktop.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ if use x86 && ! use cpu_flags_x86_sse2; then
+ append-cppflags -D_FORCE_SOFTWARE_SHA
+ fi
+ setup-wxwidgets
+
+ local myeconfargs=(
+ --disable-autoupdatecheck
+ --with-pugixml=system
+ $(use_enable nls locales)
+ $(use_with dbus)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}