summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-04-18 07:57:36 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-04-18 07:59:16 +0000
commitccfce9c458f9759f3c75ce10fbde2027d8112968 (patch)
tree76517f7f6dcbd1545fdee5d4fbb474f0bc9d4616 /net-ftp
parentnet-ftp/netkit-ftpd: Clean up old. (diff)
downloadgentoo-ccfce9c458f9759f3c75ce10fbde2027d8112968.tar.gz
gentoo-ccfce9c458f9759f3c75ce10fbde2027d8112968.tar.bz2
gentoo-ccfce9c458f9759f3c75ce10fbde2027d8112968.zip
net-ftp/netkit-ftpd: EAPI 6 bump.
--straight-to-stable because r8 is way too old and was removed (EAPI 0). Package-Manager: portage-2.2.26
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/netkit-ftpd/Manifest2
-rw-r--r--net-ftp/netkit-ftpd/netkit-ftpd-0.17-r9.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/net-ftp/netkit-ftpd/Manifest b/net-ftp/netkit-ftpd/Manifest
new file mode 100644
index 000000000000..afd1ff7cc929
--- /dev/null
+++ b/net-ftp/netkit-ftpd/Manifest
@@ -0,0 +1,2 @@
+DIST linux-ftpd-0.17-ssl.patch 36459 SHA256 0082ee6a71fdd83f61e63166f7bbba97c204cdc67f9e1bf10f2df31590fba780 SHA512 f27dd2f9a50a2b3c38131c46cdb4420f81abfdbb7cd7e70d00e864da3e4562363d585a308e57b9abce7db64ede8d02e41710101e618f6c14489193776b2b1e71 WHIRLPOOL 1c2fb70da4bd8b8e5189dc3eb4c9606b056d905e89f397938358247fcd35dea26e1728ddd752748e1cd4364c0f140cf94f6c8932e5c3ee930b8ca22379982206
+DIST linux-ftpd-0.17.tar.gz 46763 SHA256 65a0b249e38bf3c3a16dbd4d3edd2657683ca8f47b307e92007f378b21d2fa65 SHA512 160191baa904b4c404473e2c1de23813de1b31cbb11a3c28ff64f9953aec8270b74d865a57d5aaa6d25cf404c8aeadff05348a9b32847a2a137ef4c998557d58 WHIRLPOOL 5f0783a2ddc11519132db10ed837241eec8ef9cddff00891728ead29a4170858d96518bb05b8bf0dfa9204b1ed5033ffbc3d0106b9ccd1dca201e4d5a2819f46
diff --git a/net-ftp/netkit-ftpd/netkit-ftpd-0.17-r9.ebuild b/net-ftp/netkit-ftpd/netkit-ftpd-0.17-r9.ebuild
new file mode 100644
index 000000000000..7fb0443e6639
--- /dev/null
+++ b/net-ftp/netkit-ftpd/netkit-ftpd-0.17-r9.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils ssl-cert toolchain-funcs
+
+MY_P="linux-ftpd-${PV}"
+DESCRIPTION="The netkit FTP server with optional SSL support"
+HOMEPAGE="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${MY_P}.tar.gz
+ mirror://gentoo/${MY_P}-ssl.patch"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ~ppc64 s390 sh sparc x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl:0= )"
+RDEPEND="${DEPEND}
+ virtual/inetd
+ !www-servers/publicfile"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ cd "${S}" || die
+ if use ssl; then
+ epatch "${DISTDIR}"/${MY_P}-ssl.patch
+ epatch "${FILESDIR}"/${P}-cleanup-ssl.patch
+ epatch "${FILESDIR}"/${P}-fclose-CVE-2007-6263.patch #199206
+ fi
+
+ epatch "${FILESDIR}"/${P}-cleanup.patch
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-shadowfix.patch
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+ epatch "${FILESDIR}"/${P}-setguid.patch
+ epatch "${FILESDIR}"/${P}-cross.patch
+ epatch "${FILESDIR}"/${P}-CVE-2008-4247.patch #239047
+}
+
+src_configure() {
+ tc-export CC
+ ./configure --prefix=/usr || die
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ dobin ftpd/ftpd
+ doman ftpd/ftpd.8
+ dodoc README ChangeLog
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/ftp.xinetd ftp
+}
+
+pkg_postinst() {
+ if use ssl; then
+ install_cert /etc/ssl/certs/ftpd
+ elog "In order to start the server with SSL support"
+ elog "You need a certificate /etc/ssl/certs/ftpd.pem."
+ elog "A temporary certificiate has been created."
+ fi
+}