summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-28 13:47:46 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-28 13:52:57 +0200
commitdb1ac2c21d8034aa933b739f389626821e0864fb (patch)
tree01ac8a6ea8ad9285a14e04370b2a287f099181de /net-ftp
parentdev-libs/libfilezilla: bump to v0.24.1 (diff)
downloadgentoo-db1ac2c21d8034aa933b739f389626821e0864fb.tar.gz
gentoo-db1ac2c21d8034aa933b739f389626821e0864fb.tar.bz2
gentoo-db1ac2c21d8034aa933b739f389626821e0864fb.zip
net-ftp/filezilla: bump to v3.50.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.50.0.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index b1064710bb9f..3de9d5b826a2 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -2,3 +2,4 @@ DIST FileZilla_3.47.2.1_src.tar.bz2 4733941 BLAKE2B 0517d43bfba8aa116ae4031d56e5
DIST FileZilla_3.48.0_src.tar.bz2 4765599 BLAKE2B 0ab391c0862a34dd5ede7a80290afc82b4d85b2deaf42d3bacd243bddf15505f05028522f73eeada07e91d91e0af87676ad77081c843448fda53c3b2ac18a70d SHA512 c9d4eb17dc31894468ca4b7c4c8fda0f307d3931bf1b3b8fb44afd084a1b2c9309d39e5745f9ba287a5566d44089af32350703e324a559afd6a015af469433fb
DIST FileZilla_3.48.1_src.tar.bz2 4774251 BLAKE2B a77b821640aae3deaad3350809f34dbac8ed63c336435f92393017301509b91ef5e613ea64cb934dd2385b55fe7ba711269f85b7523d43ef451ab0cf6634ab0a SHA512 58792f92bb4f6102166924abaf843c023faeca7f2979aaa47c26f2bb3f8449902b4a43c50a800d56584d39c9ddf64a6d3334558e46f56bda3b8515c7a3ff0a12
DIST FileZilla_3.49.1_src.tar.bz2 4788452 BLAKE2B 63ee0ba462f918a357342f8e53dccb40e01a7cab52e25891e1b17bddb863d0386a51c67e09d0c875a4abf9b4e443a03c6616be3d7d39e585324e7343d19dfd14 SHA512 e6e69858aff3be6f557cc338ac4cd4391699d171742a2e815dff15e029a76cb1cc0651c15a3b4fb95644371b4e84b913e34a70846454a7fd5de6f05a7f461add
+DIST FileZilla_3.50.0_src.tar.bz2 4791977 BLAKE2B c0352eea9c4cd0a10d25b21b0a6982a762df6353a8da0703179270ef27be71bf151591011c45aae6e303437ac5ecca6a340635c392e2ed6db1a4a9d4002f4d7b SHA512 5edcb18aa7e4a0a59678d589d20996d7f6311f717e55a70c9dacafe42e3df6cba79be778bef34ff399672941dfb78a4732b83f21016b721702c763f0408b3e40
diff --git a/net-ftp/filezilla/filezilla-3.50.0.ebuild b/net-ftp/filezilla/filezilla-3.50.0.ebuild
new file mode 100644
index 000000000000..c567d79aeb8c
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.50.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools flag-o-matic wxwidgets xdg
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/libfilezilla-0.24.1:=
+ >=dev-libs/pugixml-1.7
+ >=net-libs/gnutls-3.5.7
+ >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( >=dev-util/cppunit-1.13.0 )"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DOCS=(AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.22.1-debug.patch
+ "${FILESDIR}"/${PN}-3.47.0-metainfo.patch
+ "${FILESDIR}"/${PN}-3.47.0-disable-shellext_conf.patch
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_prepare() {
+ setup-wxwidgets
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-autoupdatecheck
+ --with-pugixml=system
+ $(use_enable nls locales)
+ $(use_with dbus)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}