summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/reaim
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/reaim')
-rw-r--r--net-im/reaim/Manifest1
-rw-r--r--net-im/reaim/files/reaim22
-rw-r--r--net-im/reaim/metadata.xml8
-rw-r--r--net-im/reaim/reaim-0.8-r1.ebuild36
4 files changed, 67 insertions, 0 deletions
diff --git a/net-im/reaim/Manifest b/net-im/reaim/Manifest
new file mode 100644
index 000000000000..2ccd17a2f011
--- /dev/null
+++ b/net-im/reaim/Manifest
@@ -0,0 +1 @@
+DIST reaim-0.8.tar.gz 39944 SHA256 8a530d8b2ee40c63dd71f20657f324252732632778928ecccaea2a237be19eb5
diff --git a/net-im/reaim/files/reaim b/net-im/reaim/files/reaim
new file mode 100644
index 000000000000..f10cd7edcab4
--- /dev/null
+++ b/net-im/reaim/files/reaim
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net iptables
+}
+
+start() {
+ ebegin "Starting reaim"
+ iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 5190 -j REDIRECT --to-ports 5190
+ start-stop-daemon --start --quiet --exec /usr/sbin/reaim
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping reaim"
+ iptables -t nat -D PREROUTING -i eth0 -p tcp --dport 5190 -j REDIRECT --to-ports 5190
+ start-stop-daemon --stop --quiet --exec /usr/sbin/reaim
+ eend $?
+}
diff --git a/net-im/reaim/metadata.xml b/net-im/reaim/metadata.xml
new file mode 100644
index 000000000000..0a0826c95a75
--- /dev/null
+++ b/net-im/reaim/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <upstream>
+ <remote-id type="sourceforge">reaim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-im/reaim/reaim-0.8-r1.ebuild b/net-im/reaim/reaim-0.8-r1.ebuild
new file mode 100644
index 000000000000..59cb3548f7ee
--- /dev/null
+++ b/net-im/reaim/reaim-0.8-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="AIM transport proxy over NAT firewalls"
+HOMEPAGE="http://reaim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/reaim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="net-firewall/iptables"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ sed -i -e 's/gcc/$(CC) $(CFLAGS) $(LDFLAGS)/' \
+ -e 's/ -g / /' Makefile || die "sed failed" #365863
+}
+
+src_install() {
+ dosbin reaim || die
+ doman reaim.8
+ dodoc CREDITS
+ dohtml -r -x CVS html/*
+ newinitd "${FILESDIR}"/reaim reaim
+}