summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-02-17 21:38:28 +0100
committerUlrich Müller <ulm@gentoo.org>2018-02-17 21:39:00 +0100
commita0f93a170f1338640ed3ceaa60319bfd28e4d9d6 (patch)
tree522651ca8a100ad9818fde4bd6d7896c841f31c2 /net-im
parentnet-im/openmittsu: Remove old. (diff)
downloadgentoo-a0f93a170f1338640ed3ceaa60319bfd28e4d9d6.tar.gz
gentoo-a0f93a170f1338640ed3ceaa60319bfd28e4d9d6.tar.bz2
gentoo-a0f93a170f1338640ed3ceaa60319bfd28e4d9d6.zip
net-im/openmittsu: Version bump.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-im')
-rw-r--r--net-im/openmittsu/Manifest1
-rw-r--r--net-im/openmittsu/openmittsu-0.9.11.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-im/openmittsu/Manifest b/net-im/openmittsu/Manifest
index 846eeed04292..717435f54256 100644
--- a/net-im/openmittsu/Manifest
+++ b/net-im/openmittsu/Manifest
@@ -1 +1,2 @@
+DIST openmittsu-0.9.11.0.tar.xz 2076128 BLAKE2B 6aa55f1fba69d871e9f8c1c9cb787d1dbebc8474cc76285a5565580d245b52c93792d40fc436b0b3ab73939099514a439397364eeaf6ca9c2ff5ce68c020e2a2 SHA512 6cc190daac3fce456176b87193e23b6c6f078c919fb7730d614d6a3c7b6a274ec89cfac71929807672f18a0fcb00cfdb6043b3b555bf3912a1578624b0ede60a
DIST openmittsu-0.9.9.48.tar.xz 2026628 BLAKE2B eafd2bc537a22b140e01e14da363d3943e24b86754a090fd1ed2ac80f1030e1a2fb30ee8a5395c6c9a143d5922354ac67e3376a94c34f670f8cbcfddc27da112 SHA512 e24ec8e0792df13e781080fe42934035f74b82be62a8ce4913175a13ee3acbead069d169871405f4312927165a7049291d009c7f968b088bdbb3e294f9ef2443
diff --git a/net-im/openmittsu/openmittsu-0.9.11.0.ebuild b/net-im/openmittsu/openmittsu-0.9.11.0.ebuild
new file mode 100644
index 000000000000..226e2dba08f7
--- /dev/null
+++ b/net-im/openmittsu/openmittsu-0.9.11.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils desktop
+
+DESCRIPTION="An open source chat client for Threema-style end-to-end encrypted chat networks"
+HOMEPAGE="https://www.openmittsu.de/"
+# git-archive-all.sh snapshot of https://github.com/blizzard4591/openMittsu.git
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+ BitstreamVera OFL-1.1 Apache-2.0 CC0-1.0 MIT BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-db/qt5-sqlcipher
+ >=dev-libs/libsodium-1.0.11:=
+ >=dev-qt/qtcore-5.7.1:5=
+ >=dev-qt/qtgui-5.7.1:5=
+ >=dev-qt/qtmultimedia-5.7.1:5=
+ >=dev-qt/qtnetwork-5.7.1:5=[ssl]
+ >=dev-qt/qtsql-5.7.1:5=[sqlite]
+ >=dev-qt/qtwidgets-5.7.1:5=
+ >=media-gfx/qrencode-3.4.4-r1:="
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gmock )"
+
+DOCS=(
+ README.md
+ Example-client-configuration-file.ini
+ Example-contacts-file.txt
+)
+
+src_configure() {
+ local mycmakeargs=(
+ # set version manually, since autodetection works only with git
+ "-DOPENMITTSU_CUSTOM_VERSION_STRING=${PV%.*}-${PV##*.}-00000000"
+ "-DOPENMITTSU_DISABLE_VERSION_UPDATE_CHECK=ON"
+ "-DOPENMITTSU_ENABLE_TESTS=$(usex test)"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ ./openMittsuTests || die
+}
+
+src_install() {
+ local my_pn="openMittsu"
+ cmake-utils_src_install
+ newicon resources/icon.png ${my_pn}.png
+ make_desktop_entry ${my_pn} ${my_pn} ${my_pn}
+ rm "${ED}"/usr/bin/${my_pn}VersionInfo || die
+ rm -f "${ED}"/usr/bin/${my_pn}Tests || die
+}