summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-07-21 10:48:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-21 23:46:12 +0200
commitb1ff6a5fe31857bad5a74c6e412461d820d9eaa7 (patch)
tree8ce4359466b313256253c7876c4d14d0a5149124 /net-im
parentgames-fps/eduke32: drop old version (diff)
downloadgentoo-b1ff6a5fe31857bad5a74c6e412461d820d9eaa7.tar.gz
gentoo-b1ff6a5fe31857bad5a74c6e412461d820d9eaa7.tar.bz2
gentoo-b1ff6a5fe31857bad5a74c6e412461d820d9eaa7.zip
net-im/spectrum2: use correct python eclass
Switching from python-single-r1 eclass to python-any-r1 eclass, since python is only used for tests and not during runtime. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/12485 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/spectrum2/spectrum2-2.0.10.1-r2.ebuild (renamed from net-im/spectrum2/spectrum2-2.0.10.1-r1.ebuild)12
1 files changed, 8 insertions, 4 deletions
diff --git a/net-im/spectrum2/spectrum2-2.0.10.1-r1.ebuild b/net-im/spectrum2/spectrum2-2.0.10.1-r2.ebuild
index d528d2460792..be621d22a701 100644
--- a/net-im/spectrum2/spectrum2-2.0.10.1-r1.ebuild
+++ b/net-im/spectrum2/spectrum2-2.0.10.1-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils python-single-r1 systemd user
+inherit cmake-utils python-any-r1 systemd user
DESCRIPTION="An open source instant messaging transport"
HOMEPAGE="https://www.spectrum.im"
@@ -49,11 +49,11 @@ RDEPEND="
whatsapp? ( net-im/transwhat )"
DEPEND="
- ${PYTHON_DEPS}
${RDEPEND}
doc? ( app-doc/doxygen )
test? (
- dev-python/sleekxmpp[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/sleekxmpp[${PYTHON_USEDEP}]')
dev-util/cppunit
net-irc/ngircd
)
@@ -62,11 +62,15 @@ DEPEND="
# Tests are currently restricted, as they do completly fail
RESTRICT="test"
+python_check_deps() {
+ has_version "dev-python/sleekxmpp[${PYTHON_USEDEP}]"
+}
+
pkg_setup() {
enewgroup spectrum
enewuser spectrum -1 -1 /var/lib/spectrum2 spectrum
- use test && python-single-r1_pkg_setup
+ use test && python-any-r1_pkg_setup
}
src_prepare() {