summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Vinson <nvinson234@gmail.com>2016-10-15 13:24:12 -0700
committerDavid Seifert <soap@gentoo.org>2016-10-16 19:24:04 +0200
commit9c77065a52897026dc3cd4c16e8eec9273befc5c (patch)
tree31b9a683c10169ab9154fcf3c6199ccf002e8f5e /net-irc/hexchat/files
parentnet-misc/connman: add keepdir call (diff)
downloadgentoo-9c77065a52897026dc3cd4c16e8eec9273befc5c.tar.gz
gentoo-9c77065a52897026dc3cd4c16e8eec9273befc5c.tar.bz2
gentoo-9c77065a52897026dc3cd4c16e8eec9273befc5c.zip
net-irc/hexchat: fix libgdiplus.so & Werror errors
Fixes the System.DllNotFounException: libgdiplus.so error when the theme-manager USE flag is set. The problem is that only mono[minimal] is buildable right now, so mono[-minimal] does not work. However, mono[minimal] does not pull in libgdiplus.so. Therefore, the "fix" is to pull in libgdiplus as a dependency if the user is using mono[minimal]. Unfortunately, this doesn't fix the mono[-minimal] use case. Additionally, removes all Werror* flags from configure.ac. Gentoo-bug: 578290 Gentoo-bug: 597126 Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2563 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-irc/hexchat/files')
-rw-r--r--net-irc/hexchat/files/hexchat-2.12.2-configure.ac-remove-werror.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-irc/hexchat/files/hexchat-2.12.2-configure.ac-remove-werror.patch b/net-irc/hexchat/files/hexchat-2.12.2-configure.ac-remove-werror.patch
new file mode 100644
index 000000000000..7798d81c740d
--- /dev/null
+++ b/net-irc/hexchat/files/hexchat-2.12.2-configure.ac-remove-werror.patch
@@ -0,0 +1,25 @@
+The option -Werror=missing-include-dirs causes the build to fail if
+non-exsistent directories are added via -I. Removing the rest of the -Werror*
+flags to ensure no new bugs get created because a -Werror flag stopped the
+build.
+
+--- hexchat-2.12.2/configure.ac.old 2016-10-15 13:40:30.585210113 -0700
++++ hexchat-2.12.2/configure.ac 2016-10-15 13:40:44.937008119 -0700
+@@ -634,17 +634,10 @@ AX_APPEND_COMPILE_FLAGS([\
+ -Wno-unused-parameter \
+ -Wno-sign-compare \
+ -Wno-pointer-sign \
+ -Wno-missing-field-initializers \
+ -Wno-unused-result \
+- -Werror=format-security \
+- -Werror=init-self \
+- -Werror=declaration-after-statement \
+- -Werror=missing-include-dirs \
+- -Werror=date-time \
+- -Werror=implicit-function-declaration \
+- -Werror=pointer-arith \
+ ])
+
+ AS_IF([test "$stack_protector" = "yes"], [
+ AX_APPEND_COMPILE_FLAGS([ \
+ -fstack-protector-strong \