summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-07-30 20:57:43 +0200
committerPacho Ramos <pacho@gentoo.org>2024-07-30 21:00:42 +0200
commitf071a66c43185ce2ca6a68ca0a97edef7b1496e5 (patch)
treef885ae692772814cdc7a97475ef7e8920c4dfc7a /net-irc
parentnet-irc/limnoria: sync live ebuild (diff)
downloadgentoo-f071a66c43185ce2ca6a68ca0a97edef7b1496e5.tar.gz
gentoo-f071a66c43185ce2ca6a68ca0a97edef7b1496e5.tar.bz2
gentoo-f071a66c43185ce2ca6a68ca0a97edef7b1496e5.zip
net-irc/limnoria: drop 20220814, 20220927, 20221116
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/limnoria/Manifest2
-rw-r--r--net-irc/limnoria/limnoria-20220814.ebuild78
-rw-r--r--net-irc/limnoria/limnoria-20220927.ebuild78
-rw-r--r--net-irc/limnoria/limnoria-20221116.ebuild78
4 files changed, 0 insertions, 236 deletions
diff --git a/net-irc/limnoria/Manifest b/net-irc/limnoria/Manifest
index 0e35b0e6a2a3..2ead8f1cfcc1 100644
--- a/net-irc/limnoria/Manifest
+++ b/net-irc/limnoria/Manifest
@@ -1,3 +1 @@
-DIST limnoria-20220814.tar.gz 1124320 BLAKE2B f2c32a444726d7e25560a7408c11c4c9d4536823eda2e4eb7b57b880f5d3aaf5c6e560d6b912c2e4b35b04e6d4f767f66aa5bd2411b9820644bef3372a34deb6 SHA512 7a7e73c9c4583310dbe0032e2b058977c102d01f7b9bea03c505153cbc45dadb88087186c036e05b1d07c7361d3e2d077a669a857241152a6726245b8b424317
-DIST limnoria-20220927.tar.gz 1125411 BLAKE2B f10c112c59e74ad018291df770ad9ae8829f90cb57125e7be066964e9987a069ff778dc8c3e562fe2f04627c173d611f6089975d0b44c47b72a9c41fcb429983 SHA512 9e8d57c34d1ff23e1772be618d9f9a8fae909200d3002ea97a95a5ba6545781d68194c4c796fa7f8683a0f3a267566ade01dd74f26110e7e0febef8ff739d88a
DIST limnoria-20221116.tar.gz 1125332 BLAKE2B b5007cb832ea98f41ad9513554177eab2cf7948b363c4cfad538a7e4c4f91390625bbf187e046118551da2fbe8272968acb1280b8d4ea19ffe2ac67b2b83af92 SHA512 3c26a36b7094d2a36397d7d0cfbb9b9503b6beaec123c6022146a5c241e5cc2ff70c56ad4064269b315d2f5c07e9e09853f27b251b35d3efc3065c4831742e2c
diff --git a/net-irc/limnoria/limnoria-20220814.ebuild b/net-irc/limnoria/limnoria-20220814.ebuild
deleted file mode 100644
index 89a8614cf3dd..000000000000
--- a/net-irc/limnoria/limnoria-20220814.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_IN_SOURCE_BUILD=yes # needed for tests
-inherit distutils-r1
-
-MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-MY_PN="Limnoria"
-MY_P="${MY_PN}-${MY_PV}"
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://github.com/ProgVal/${MY_PN}.git"
- EGIT_BRANCH="testing"
- inherit git-r3
-else
- SRC_URI="https://github.com/ProgVal/${MY_PN}/archive/master-${MY_PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${MY_PN}-master-${MY_PV}"
- KEYWORDS="~amd64 ~riscv ~x86"
-fi
-
-DESCRIPTION="Python based extensible IRC infobot and channel bot"
-HOMEPAGE="https://docs.limnoria.net"
-LICENSE="BSD GPL-2 GPL-2+"
-SLOT="0"
-IUSE="crypt ssl test"
-RESTRICT=" !test? ( test )"
-
-RDEPEND="
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/ecdsa[${PYTHON_USEDEP}]
- dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/PySocks[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- crypt? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
- ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )"
-BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # replace "installed on ${timestamp}" with real version
- echo "version='${MY_PV//-/.}'" > "${S}"/src/version.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pushd "${T}" > /dev/null || die
- PLUGINS_DIR="${BUILD_DIR}"/lib/supybot/plugins
- EXCLUDE_PLUGINS=()
- # intermittent failure due to issues loading libsandbox.so from LD_PRELOAD
- # runs successfully when running the tests on the installed system
- EXCLUDE_PLUGINS+=(
- --exclude="${PLUGINS_DIR}/Unix"
- --exclude="${PLUGINS_DIR}/Aka"
- --exclude="${PLUGINS_DIR}/Misc"
- )
- "${EPYTHON}" "${BUILD_DIR}"/scripts/supybot-test "${BUILD_DIR}/../test" \
- --plugins-dir="${PLUGINS_DIR}" --no-network \
- --disable-multiprocessing "${EXCLUDE_PLUGINS[@]}" \
- || die "Tests failed under ${EPYTHON}"
- popd > /dev/null || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- doman man/*
-}
-
-pkg_postinst() {
- elog "Complete user documentation is available at https://limnoria-doc.readthedocs.org/"
- elog ""
- elog "Use supybot-wizard to create a configuration file."
- elog "Run supybot </path/to/config> to use the bot."
-}
diff --git a/net-irc/limnoria/limnoria-20220927.ebuild b/net-irc/limnoria/limnoria-20220927.ebuild
deleted file mode 100644
index 89a8614cf3dd..000000000000
--- a/net-irc/limnoria/limnoria-20220927.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_IN_SOURCE_BUILD=yes # needed for tests
-inherit distutils-r1
-
-MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-MY_PN="Limnoria"
-MY_P="${MY_PN}-${MY_PV}"
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://github.com/ProgVal/${MY_PN}.git"
- EGIT_BRANCH="testing"
- inherit git-r3
-else
- SRC_URI="https://github.com/ProgVal/${MY_PN}/archive/master-${MY_PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${MY_PN}-master-${MY_PV}"
- KEYWORDS="~amd64 ~riscv ~x86"
-fi
-
-DESCRIPTION="Python based extensible IRC infobot and channel bot"
-HOMEPAGE="https://docs.limnoria.net"
-LICENSE="BSD GPL-2 GPL-2+"
-SLOT="0"
-IUSE="crypt ssl test"
-RESTRICT=" !test? ( test )"
-
-RDEPEND="
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/ecdsa[${PYTHON_USEDEP}]
- dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/PySocks[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- crypt? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
- ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )"
-BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # replace "installed on ${timestamp}" with real version
- echo "version='${MY_PV//-/.}'" > "${S}"/src/version.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pushd "${T}" > /dev/null || die
- PLUGINS_DIR="${BUILD_DIR}"/lib/supybot/plugins
- EXCLUDE_PLUGINS=()
- # intermittent failure due to issues loading libsandbox.so from LD_PRELOAD
- # runs successfully when running the tests on the installed system
- EXCLUDE_PLUGINS+=(
- --exclude="${PLUGINS_DIR}/Unix"
- --exclude="${PLUGINS_DIR}/Aka"
- --exclude="${PLUGINS_DIR}/Misc"
- )
- "${EPYTHON}" "${BUILD_DIR}"/scripts/supybot-test "${BUILD_DIR}/../test" \
- --plugins-dir="${PLUGINS_DIR}" --no-network \
- --disable-multiprocessing "${EXCLUDE_PLUGINS[@]}" \
- || die "Tests failed under ${EPYTHON}"
- popd > /dev/null || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- doman man/*
-}
-
-pkg_postinst() {
- elog "Complete user documentation is available at https://limnoria-doc.readthedocs.org/"
- elog ""
- elog "Use supybot-wizard to create a configuration file."
- elog "Run supybot </path/to/config> to use the bot."
-}
diff --git a/net-irc/limnoria/limnoria-20221116.ebuild b/net-irc/limnoria/limnoria-20221116.ebuild
deleted file mode 100644
index 4c9f1af4daec..000000000000
--- a/net-irc/limnoria/limnoria-20221116.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_IN_SOURCE_BUILD=yes # needed for tests
-inherit distutils-r1
-
-MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-MY_PN="Limnoria"
-MY_P="${MY_PN}-${MY_PV}"
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://github.com/ProgVal/${MY_PN}.git"
- EGIT_BRANCH="testing"
- inherit git-r3
-else
- SRC_URI="https://github.com/ProgVal/${MY_PN}/archive/master-${MY_PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${MY_PN}-master-${MY_PV}"
- KEYWORDS="~amd64 ~riscv ~x86"
-fi
-
-DESCRIPTION="Python based extensible IRC infobot and channel bot"
-HOMEPAGE="https://docs.limnoria.net"
-LICENSE="BSD GPL-2 GPL-2+"
-SLOT="0"
-IUSE="crypt ssl test"
-RESTRICT=" !test? ( test )"
-
-RDEPEND="
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/ecdsa[${PYTHON_USEDEP}]
- dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/PySocks[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- crypt? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
- ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )"
-BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # replace "installed on ${timestamp}" with real version
- echo "version='${MY_PV//-/.}'" > "${S}"/src/version.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pushd "${T}" > /dev/null || die
- PLUGINS_DIR="${BUILD_DIR}"/lib/supybot/plugins
- EXCLUDE_PLUGINS=()
- # intermittent failure due to issues loading libsandbox.so from LD_PRELOAD
- # runs successfully when running the tests on the installed system
- EXCLUDE_PLUGINS+=(
- --exclude="${PLUGINS_DIR}/Unix"
- --exclude="${PLUGINS_DIR}/Aka"
- --exclude="${PLUGINS_DIR}/Misc"
- )
- "${EPYTHON}" "${BUILD_DIR}"/scripts/supybot-test "${BUILD_DIR}/../test" \
- --plugins-dir="${PLUGINS_DIR}" --no-network \
- --disable-multiprocessing "${EXCLUDE_PLUGINS[@]}" \
- || die "Tests failed under ${EPYTHON}"
- popd > /dev/null || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- doman man/*
-}
-
-pkg_postinst() {
- elog "Complete user documentation is available at https://limnoria-doc.readthedocs.org/"
- elog ""
- elog "Use supybot-wizard to create a configuration file."
- elog "Run supybot </path/to/config> to use the bot."
-}