summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-06-23 21:02:41 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-10-23 14:24:24 +0200
commitbadbc6598381730ae936d4132b60c9206ecbeffa (patch)
tree7aa707e509b8c88c1edd145422f9bf657592e4d7 /net-libs/NativeThread
parentdev-java/mersennetwister: eapi7, min java 1.8 (diff)
downloadgentoo-badbc6598381730ae936d4132b60c9206ecbeffa.tar.gz
gentoo-badbc6598381730ae936d4132b60c9206ecbeffa.tar.bz2
gentoo-badbc6598381730ae936d4132b60c9206ecbeffa.zip
net-libs/NativeThread: min java 1.8
Bug: https://bugs.gentoo.org/787629 restricted to :1.8 as it doesn't work with java 11 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/21395 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'net-libs/NativeThread')
-rw-r--r--net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild b/net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild
new file mode 100644
index 000000000000..f0565f04c47b
--- /dev/null
+++ b/net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic java-pkg-2 toolchain-funcs
+
+DESCRIPTION="NativeThread for priorities on linux for freenet"
+HOMEPAGE="https://www.freenetproject.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=net-p2p/freenet-0.7
+ virtual/jdk:1.8"
+RDEPEND="virtual/jre:1.8"
+
+S="${WORKDIR}"
+
+src_compile() {
+ append-flags -fPIC
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dolib.so lib${PN}.so
+ dosym lib${PN}.so /usr/$(get_libdir)/libnative.so
+}