summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-05-29 14:22:36 +0200
committerPacho Ramos <pacho@gentoo.org>2016-05-29 14:41:41 +0200
commit3ec66f9cb2d49abd39ad77656d55950cdff3dd68 (patch)
treeb11f4b1cd941cbe62baad2a1f6a620304b19522e /net-libs/libdmapsharing
parentnet-libs/libdmapsharing: Drop old (diff)
downloadgentoo-3ec66f9cb2d49abd39ad77656d55950cdff3dd68.tar.gz
gentoo-3ec66f9cb2d49abd39ad77656d55950cdff3dd68.tar.bz2
gentoo-3ec66f9cb2d49abd39ad77656d55950cdff3dd68.zip
net-libs/libdmapsharing: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'net-libs/libdmapsharing')
-rw-r--r--net-libs/libdmapsharing/Manifest1
-rw-r--r--net-libs/libdmapsharing/libdmapsharing-2.9.35.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/libdmapsharing/Manifest b/net-libs/libdmapsharing/Manifest
index 2537c8217753..7ed4505e32a4 100644
--- a/net-libs/libdmapsharing/Manifest
+++ b/net-libs/libdmapsharing/Manifest
@@ -1 +1,2 @@
DIST libdmapsharing-2.9.32.tar.gz 742229 SHA256 74b9ca2a3f04708ef5e6a87922cb42bad677b6f27fd0bc8ad53067ef6bbf0518 SHA512 fd152749055dd02fefa672f7da3efc85bffa7ddb10880886dff829fc8abfaecc79131366fdf31f5657c1b5e622c04f3dbfc750998ea56ffaf9af800210b17084 WHIRLPOOL f8fb493eb9181a18ef1d2dacd44920f8312db344df7aa1f842764ef95591d03fd511fab4e3c1c2e4966caa8738db9227031a458a892cec16c2158381701b8484
+DIST libdmapsharing-2.9.35.tar.gz 759676 SHA256 619f72ad8c33e9c1e323afabe793008227099e488c71e8f9ecb404eeb32b49e7 SHA512 5755fe4f8d69ea8d58261e0068dc8dce9828c8134f53103f3afbba6d99cfe1e9f4a72f8004b96e6ac8d2bab6fb3c2cb458d9c3b333af78ee5eeb0883b5f763e8 WHIRLPOOL c1cded2d25de1f88f0ce944ef91946bcf423991e96bee1567a1d4ee46051e88771d09960ce23ea864ca73920e52fc64867ee0913f7a81e3ef3536e5d8b831bc4
diff --git a/net-libs/libdmapsharing/libdmapsharing-2.9.35.ebuild b/net-libs/libdmapsharing/libdmapsharing-2.9.35.ebuild
new file mode 100644
index 000000000000..324d722e0b3b
--- /dev/null
+++ b/net-libs/libdmapsharing/libdmapsharing-2.9.35.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A library that implements the DMAP family of protocols"
+HOMEPAGE="http://www.flyn.org/projects/libdmapsharing"
+SRC_URI="http://www.flyn.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="3.0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection test"
+
+# Vala/libgee/gtk+:2 is only used when maintainer-mode is enabled
+# Doesn't seem to be used for anything...
+# TODO: implement tests (requires dev-libs/check)
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ x11-libs/gdk-pixbuf:2
+ >=net-dns/avahi-0.6[dbus]
+ >=net-libs/libsoup-2.48.0:2.4
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ sys-libs/zlib
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+src_prepare() {
+ # Remove useless CFLAGS alteration in configure
+ sed -e 's/CFLAGS -O2/CFLAGS/' \
+ -i configure.ac configure || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --with-mdns=avahi \
+ $(use_enable introspection) \
+ $(use_enable test tests)
+}