summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-08-27 14:24:48 +0200
committerJohannes Huber <johu@gentoo.org>2015-08-27 14:24:48 +0200
commitb25ff8de385a6a27c23237fa8ec1880b461af68e (patch)
treeec6178ae65216311e63c1b08fb0bcecb26ecdc87 /net-libs/libsignon-glib
parentnet-libs/signon-oauth2: New package (diff)
downloadgentoo-b25ff8de385a6a27c23237fa8ec1880b461af68e.tar.gz
gentoo-b25ff8de385a6a27c23237fa8ec1880b461af68e.tar.bz2
gentoo-b25ff8de385a6a27c23237fa8ec1880b461af68e.zip
net-libs/libsignon-glib: New package
Initial ebuild by Igor Poboiko <igor.poboiko@gmail.com>. Updates by me. Gentoo-Bug: 557546 Reported-by: David E. Narváez <david.narvaez@computer.org> Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-libs/libsignon-glib')
-rw-r--r--net-libs/libsignon-glib/Manifest1
-rw-r--r--net-libs/libsignon-glib/files/libsignon-glib-1.12-doc-disable.patch25
-rw-r--r--net-libs/libsignon-glib/libsignon-glib-1.12.ebuild76
-rw-r--r--net-libs/libsignon-glib/metadata.xml5
4 files changed, 107 insertions, 0 deletions
diff --git a/net-libs/libsignon-glib/Manifest b/net-libs/libsignon-glib/Manifest
new file mode 100644
index 000000000000..48c9856f6ca9
--- /dev/null
+++ b/net-libs/libsignon-glib/Manifest
@@ -0,0 +1 @@
+DIST libsignon-glib-1.12.tar.xz 42384 SHA256 bd7e3be291e3173f20dda5376e1387be5d1705b12a00885e93f2cc900a9b4463 SHA512 5d5a3918898dce9d8b10597ac95428bef4753a1c626b6e7fef54e9024327b0849ddb628b25801504c336cf6fe2ebc16e5264bb576ecab16457ccf17918f042cf WHIRLPOOL 5766ad1fe50a6637d2f8e5fe6b092599112c9b6fb56dd44502568d41d61d3208d8d5a00ce1c698848f3fbeb0eb0a1ee82bcbebaff74428a97f634589e56d9def
diff --git a/net-libs/libsignon-glib/files/libsignon-glib-1.12-doc-disable.patch b/net-libs/libsignon-glib/files/libsignon-glib-1.12-doc-disable.patch
new file mode 100644
index 000000000000..1ef64e604164
--- /dev/null
+++ b/net-libs/libsignon-glib/files/libsignon-glib-1.12-doc-disable.patch
@@ -0,0 +1,25 @@
+diff -Naur libsignon-glib-1.12.old/configure.ac libsignon-glib-1.12/configure.ac
+--- libsignon-glib-1.12.old/configure.ac 2014-12-09 11:52:37.000000000 +0300
++++ libsignon-glib-1.12/configure.ac 2015-08-27 13:00:54.501123031 +0300
+@@ -100,9 +100,6 @@
+ Makefile
+ libsignon-glib/Makefile
+ libsignon-glib.pc
+- docs/Makefile
+- docs/reference/Makefile
+- docs/reference/version.xml
+ tests/Makefile
+ pygobject/Makefile
+ ])
+diff -Naur libsignon-glib-1.12.old/Makefile.am libsignon-glib-1.12/Makefile.am
+--- libsignon-glib-1.12.old/Makefile.am 2014-12-09 11:52:37.000000000 +0300
++++ libsignon-glib-1.12/Makefile.am 2015-08-27 13:00:42.101237854 +0300
+@@ -2,7 +2,7 @@
+ DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-gtk-doc \
+ --enable-introspection=yes
+-SUBDIRS = libsignon-glib docs
++SUBDIRS = libsignon-glib
+
+ if ENABLE_PYTHON
+ SUBDIRS += pygobject
diff --git a/net-libs/libsignon-glib/libsignon-glib-1.12.ebuild b/net-libs/libsignon-glib/libsignon-glib-1.12.ebuild
new file mode 100644
index 000000000000..c5f085e30bcf
--- /dev/null
+++ b/net-libs/libsignon-glib/libsignon-glib-1.12.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit autotools python-r1
+
+DESCRIPTION="GLib binding for the D-Bus API provided by signond"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="http://dev.gentoo.org/~johu/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc python test"
+
+RDEPEND="
+ dev-libs/glib:2
+ net-libs/signond
+"
+DEPEND="${RDEPEND}
+ dev-libs/check
+ python? ( ${PYTHON_DEPS} )
+ doc? ( dev-util/gtk-doc )
+"
+
+DOCS=( AUTHORS NEWS README )
+
+# needs more love
+RESTRICT="test"
+
+src_prepare() {
+ if ! use doc; then
+ epatch "${FILESDIR}/${P}-doc-disable.patch"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ myconfigure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable doc gtk-doc)
+ $(use_enable python)
+ $(use_enable test tests)
+ )
+
+ econf "${myeconfargs[@]}"
+ }
+
+ if use python; then
+ python_copy_sources
+ python_foreach_impl run_in_build_dir myconfigure
+ else
+ myconfigure
+ fi
+}
+
+src_compile() {
+ # fails to compile with more than one thread
+ MAKEOPTS="${MAKEOPTS} -j1"
+ default
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ fi
+}
+
+src_install() {
+ default
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ fi
+}
diff --git a/net-libs/libsignon-glib/metadata.xml b/net-libs/libsignon-glib/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/net-libs/libsignon-glib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>