summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-02 15:15:56 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-02 15:15:56 +0200
commit33937f23c9c109caeb28da7d5f968808ef1c063c (patch)
tree62e6b565d546910fdcc00ed3ec12475e73729f79 /net-libs/rpc2/rpc2-2.14-r1.ebuild
parentsys-fs/multipath-tools: add 0.9.0 (diff)
downloadgentoo-33937f23c9c109caeb28da7d5f968808ef1c063c.tar.gz
gentoo-33937f23c9c109caeb28da7d5f968808ef1c063c.tar.bz2
gentoo-33937f23c9c109caeb28da7d5f968808ef1c063c.zip
net-libs/rpc2: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/716076 Closes: https://bugs.gentoo.org/725048 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs/rpc2/rpc2-2.14-r1.ebuild')
-rw-r--r--net-libs/rpc2/rpc2-2.14-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-libs/rpc2/rpc2-2.14-r1.ebuild b/net-libs/rpc2/rpc2-2.14-r1.ebuild
new file mode 100644
index 000000000000..6e2f4af36aa0
--- /dev/null
+++ b/net-libs/rpc2/rpc2-2.14-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Remote procedure call package for IP/UDP (used by Coda)"
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="http://www.coda.cs.cmu.edu/pub/rpc2/src/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc x86"
+
+RDEPEND=">=sys-libs/lwp-2.5"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-respect-flags.patch
+ "${FILESDIR}"/${P}-include.patch
+)
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}