summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Písař <petr.pisar@atlas.cz>2022-04-03 17:50:04 +0200
committerSam James <sam@gentoo.org>2024-03-12 02:22:53 +0000
commit23615637caf8574a828a1d76f4af3c2406635bb8 (patch)
tree479fbb4087ca2de6b94d7dc1cb7fe65d4563cc45 /net-libs
parentsci-mathematics/nauty: fix build with autoconf-2.72 (diff)
downloadgentoo-23615637caf8574a828a1d76f4af3c2406635bb8.tar.gz
gentoo-23615637caf8574a828a1d76f4af3c2406635bb8.tar.bz2
gentoo-23615637caf8574a828a1d76f4af3c2406635bb8.zip
net-libs/libisds: Bump to 0.11.2
Closes: https://bugs.gentoo.org/836628 Signed-off-by: Petr Písař <petr.pisar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libisds/Manifest1
-rw-r--r--net-libs/libisds/libisds-0.11.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/net-libs/libisds/Manifest b/net-libs/libisds/Manifest
index 3314dc794a8b..4e6dad3848ab 100644
--- a/net-libs/libisds/Manifest
+++ b/net-libs/libisds/Manifest
@@ -1 +1,2 @@
DIST libisds-0.11.1.tar.xz 741992 BLAKE2B e1895450b1148c63a365a569fcdfa0d3cf3f2cdd011da6dbe92ea876aa1a9082470f3c7efc5757766df7e870559dd4ba62b59973e22d47401ef575e0fd412ec1 SHA512 8baf126ebf49c5eae6aa7b8f872ad90882a9a5088c8a33ffb415983eaf1ffc1df489f44ae6ba14a69a94bc4f79f455c7937276885afaa29e61c5c67408f7080a
+DIST libisds-0.11.2.tar.xz 746388 BLAKE2B 08e5e1ba5c100faf18e4fa3d89b66486b773be4cf9097f9b237c8f407a98ac2cac0337bcb2665072f65414c06ee26f5670ee2604c8420eb12990b51534eaa062 SHA512 edaa591eda18dc0b8cc7c6e29a36610845cc293f1665a2e9744ec904aaa1c561caa41ada2e87de9428bb0397772c0c2884412fd0474daf28528d7ef2a7f28426
diff --git a/net-libs/libisds/libisds-0.11.2.ebuild b/net-libs/libisds/libisds-0.11.2.ebuild
new file mode 100644
index 000000000000..dca50bdddc75
--- /dev/null
+++ b/net-libs/libisds/libisds-0.11.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Client library for accessing ISDS Soap services"
+HOMEPAGE="http://xpisar.wz.cz/libisds/"
+SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.xz"
+KEYWORDS="~amd64 ~mips ~x86"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="+curl debug doc nls openssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/libxml2
+ curl? ( net-misc/curl[ssl] )
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )
+ openssl? ( dev-libs/openssl:= )
+ !openssl? (
+ app-crypt/gnupg
+ app-crypt/gpgme:=
+ dev-libs/libgcrypt:=
+ )"
+DEPEND="${RDEPEND}
+ test? ( net-libs/gnutls )"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-fatalwarnings
+ --disable-static
+ $(use_with curl libcurl)
+ $(use_enable curl curlreauthorizationbug)
+ $(use_enable doc)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable openssl openssl-backend)
+ $(use_enable test)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}