summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-06-08 15:12:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-06-08 15:13:06 +0200
commit5fab2d9e430bb5d9bdcfb53fad904a00d7a5e382 (patch)
tree194963c7053d069b94f97f536a3079e6bfb13c26 /net-libs
parentnet-libs/libquotient: Add missing dependencies (diff)
downloadgentoo-5fab2d9e430bb5d9bdcfb53fad904a00d7a5e382.tar.gz
gentoo-5fab2d9e430bb5d9bdcfb53fad904a00d7a5e382.tar.bz2
gentoo-5fab2d9e430bb5d9bdcfb53fad904a00d7a5e382.zip
net-libs/libquotient: drop 0.7.2-r1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libquotient/libquotient-0.7.2-r1.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/net-libs/libquotient/libquotient-0.7.2-r1.ebuild b/net-libs/libquotient/libquotient-0.7.2-r1.ebuild
deleted file mode 100644
index a83821446a80..000000000000
--- a/net-libs/libquotient/libquotient-0.7.2-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Qt-based SDK to develop applications for Matrix"
-HOMEPAGE="https://github.com/quotient-im/libQuotient"
-SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/libQuotient-${PV}"
-
-LICENSE="LGPL-2+"
-SLOT="0/$(ver_cut 1-2)"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/libqtolm
- dev-libs/olm
- dev-libs/qtkeychain:=[qt5(+)]
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5[ssl]
-"
-DEPEND="${RDEPEND}
- test? (
- dev-qt/qtconcurrent:5
- dev-qt/qttest:5
- )
-"
-
-PATCHES=(
- # downstream patches
- "${FILESDIR}"/${PN}-0.7.0-no-android.patch
- "${FILESDIR}"/${PN}-0.7.0-no-tests.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_WITH_QT6=OFF
- -DBUILD_TESTING=$(usex test)
- -DQuotient_ENABLE_E2EE=ON
- )
- use test && mycmakeargs+=(
- -DQuotient_INSTALL_TESTS=OFF
- )
- cmake_src_configure
-}
-
-src_test() {
- # https://github.com/quotient-im/libQuotient/issues/435
- # testolmaccount requires network connection/server set up
- local myctestargs=(
- -j1
- -E "(testolmaccount)"
- )
- cmake_src_test
-}