summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-02-02 07:00:11 +0500
committerJoonas Niilola <juippis@gentoo.org>2024-02-28 08:55:11 +0200
commitd245e07cf011e5c7725f21b31c97a308ba661102 (patch)
tree9565dc07adb35e43c9af36d552b847bcfe746218 /net-libs
parentdev-embedded/esptool: add 4.7.0 (diff)
downloadgentoo-d245e07cf011e5c7725f21b31c97a308ba661102.tar.gz
gentoo-d245e07cf011e5c7725f21b31c97a308ba661102.tar.bz2
gentoo-d245e07cf011e5c7725f21b31c97a308ba661102.zip
net-libs/neon: add 0.33.0
Patches are dropped (applied upstream). Cosmetic changes: * Install HTML docs unconditionally * Use array for econf instead of backslash-escaped lines Closes: https://bugs.gentoo.org/922113 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in> Closes: https://github.com/gentoo/gentoo/pull/35141 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/neon/Manifest1
-rw-r--r--net-libs/neon/neon-0.33.0.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/net-libs/neon/Manifest b/net-libs/neon/Manifest
index 3385d6cdc0b5..38b6d4682213 100644
--- a/net-libs/neon/Manifest
+++ b/net-libs/neon/Manifest
@@ -1 +1,2 @@
DIST neon-0.32.4.tar.gz 895482 BLAKE2B 917f17739976e159bf91f7c594e59c96bb8b92e39c19f5c881354c11951233d3157f6871e4ebc073d493170844e516acc36be4787dbe2005c33b1ec84ae0d364 SHA512 82bcd1555f047d26cc5ccd67d2fef8dea4eb5a4cc45ca8030d2f3c356eee03fd78efd7ef45f516948e89f1089686731046b3fe48e73b3d84c65848ef6d86bd7a
+DIST neon-0.33.0.tar.gz 912146 BLAKE2B 8457e0203fcfbd9209718d139169780898f823d71b950f370f8880c5ec97c7bc5d300b8485803f75e2531a3f58fe6eb78ac5d7a82f57f12078513a3bfd0223b3 SHA512 b214ed34cd832dfaf3af08d4bdbe459c3e791f691548a6d44ee0cdc9811856185522bcbd6c2aca9a536fc021a2ed6329bd093cb3435cc40e3cfd9f5af8b92644
diff --git a/net-libs/neon/neon-0.33.0.ebuild b/net-libs/neon/neon-0.33.0.ebuild
new file mode 100644
index 000000000000..4f5ede0e48f4
--- /dev/null
+++ b/net-libs/neon/neon-0.33.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 2001-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools libtool multilib-minimal
+
+DESCRIPTION="HTTP and WebDAV client library"
+HOMEPAGE="https://notroj.github.io/neon/ https://github.com/notroj/neon"
+SRC_URI="https://notroj.github.io/neon/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/27"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="+expat gnutls kerberos libproxy nls pkcs11 ssl test zlib"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ expat? ( dev-libs/expat:0=[${MULTILIB_USEDEP}] )
+ !expat? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
+ kerberos? ( virtual/krb5:0=[${MULTILIB_USEDEP}] )
+ libproxy? ( net-libs/libproxy:0=[${MULTILIB_USEDEP}] )
+ nls? ( virtual/libintl:0=[${MULTILIB_USEDEP}] )
+ ssl? (
+ gnutls? (
+ app-misc/ca-certificates
+ net-libs/gnutls:0=[${MULTILIB_USEDEP}]
+ )
+ !gnutls? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ pkcs11? ( dev-libs/pakchois:0=[${MULTILIB_USEDEP}] )
+ )
+ zlib? ( sys-libs/zlib:0=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ ssl? (
+ dev-libs/openssl:0
+ pkcs11? ( dev-libs/nss )
+ )
+ )
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/neon-config
+)
+
+DOCS=( AUTHORS BUGS NEWS README.md THANKS TODO )
+HTML_DOCS=( doc/html/. )
+
+src_prepare() {
+ if use gnutls; then
+ # Ignore failure of test pkcs11.
+ # https://github.com/notroj/neon/issues/72
+ sed -e "s/T(pkcs11)/T_XFAIL(pkcs11)/" -i test/ssl.c || die
+ fi
+
+ default
+
+ AT_M4DIR="macros" eautoreconf
+
+ elibtoolize
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --enable-shared
+ $(use_with kerberos gssapi)
+ $(use_with libproxy)
+ $(use_enable nls)
+ $(use_with pkcs11 pakchois)
+ $(use_with zlib)
+ )
+
+ if has_version sys-libs/glibc; then
+ einfo "Enabling SSL library thread-safety using POSIX threads..."
+ myconf+=( --enable-threadsafe-ssl=posix )
+ fi
+
+ if use expat; then
+ myconf+=( --with-expat )
+ else
+ myconf+=( --with-libxml2 )
+ fi
+
+ if use ssl; then
+ if use gnutls; then
+ myconf+=(
+ --with-ssl=gnutls
+ --with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt"
+ )
+ else
+ myconf+=( --with-ssl=openssl )
+ fi
+ fi
+
+ econf "${myconf[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install-{config,headers,lib,man,nls}
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name "*.la" -delete || die
+
+ einstalldocs
+}