summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-02-28 09:12:14 +0100
committerJeroen Roovers <jer@gentoo.org>2017-02-28 09:13:12 +0100
commite0c65f4377832ca0fab3ba02f26b174263df65b6 (patch)
treef46165e9a5e9cc134feeaf48c57583a6b469ddbd /net-libs
parentdev-python/hgdistver: arm64 stable. (diff)
downloadgentoo-e0c65f4377832ca0fab3ba02f26b174263df65b6.tar.gz
gentoo-e0c65f4377832ca0fab3ba02f26b174263df65b6.tar.bz2
gentoo-e0c65f4377832ca0fab3ba02f26b174263df65b6.zip
net-libs/libtrace: Install most headers in subdir (bug #604660).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtrace/files/libtrace-4.0.0-headers.patch14
-rw-r--r--net-libs/libtrace/libtrace-4.0.0-r1.ebuild60
2 files changed, 74 insertions, 0 deletions
diff --git a/net-libs/libtrace/files/libtrace-4.0.0-headers.patch b/net-libs/libtrace/files/libtrace-4.0.0-headers.patch
new file mode 100644
index 000000000000..589bf97cb085
--- /dev/null
+++ b/net-libs/libtrace/files/libtrace-4.0.0-headers.patch
@@ -0,0 +1,14 @@
+diff --git a/lib/Makefile.am b/lib/Makefile.am
+index 5a5ca35..6c0a8f2 100644
+--- a/lib/Makefile.am
++++ b/lib/Makefile.am
+@@ -1,6 +1,7 @@
+ lib_LTLIBRARIES = libtrace.la
+-include_HEADERS = libtrace.h dagformat.h lt_inttypes.h daglegacy.h \
+- rt_protocol.h erftypes.h libtrace_parallel.h \
++include_HEADERS = libtrace.h libtrace_parallel.h
++pkginclude_HEADERS = dagformat.h lt_inttypes.h daglegacy.h \
++ rt_protocol.h erftypes.h \
+ data-struct/ring_buffer.h data-struct/object_cache.h \
+ data-struct/vector.h data-struct/message_queue.h \
+ data-struct/deque.h data-struct/linked_list.h \
diff --git a/net-libs/libtrace/libtrace-4.0.0-r1.ebuild b/net-libs/libtrace/libtrace-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..749f44a9642c
--- /dev/null
+++ b/net-libs/libtrace/libtrace-4.0.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="A library and tools for trace processing"
+HOMEPAGE="http://research.wand.net.nz/software/libtrace.php"
+SRC_URI="http://research.wand.net.nz/software/${PN}/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ncurses numa static-libs"
+
+RDEPEND="
+ >=net-libs/libpcap-0.8
+ dev-libs/openssl:0=
+ ncurses? ( sys-libs/ncurses:0= )
+ net-libs/wandio
+ numa? ( sys-process/numactl )
+"
+DEPEND="
+ ${RDEPEND}
+ app-doc/doxygen
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.20-autoconf-1.13.patch
+ "${FILESDIR}"/${PN}-3.0.20-tinfo.patch
+ "${FILESDIR}"/${PN}-4.0.0-headers.patch
+ "${FILESDIR}"/${PN}-4.0.0-no-examples.patch
+ "${FILESDIR}"/${PN}-4.0.0-with-numa.patch
+)
+S=${WORKDIR}/${P/_beta/}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with ncurses) \
+ $(use_with numa) \
+ --with-man
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r docs/doxygen/html
+
+ prune_libtool_files --modules
+}