summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-06-09 07:52:03 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-06-09 07:52:17 -0400
commit0ea6f1cfb64830aee85e31828e46225735fafa29 (patch)
treefdca553ec8649df93e5e61518dc3e6abc4979b53 /net-mail/mailshears/mailshears-0.0.5.ebuild
parentwww-client/chromium-bin: add ppc64le without KEYWORDS (diff)
downloadgentoo-0ea6f1cfb64830aee85e31828e46225735fafa29.tar.gz
gentoo-0ea6f1cfb64830aee85e31828e46225735fafa29.tar.bz2
gentoo-0ea6f1cfb64830aee85e31828e46225735fafa29.zip
net-mail/mailshears: new upstream v0.0.5.
Supports newer rubies and postgresql-14. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-mail/mailshears/mailshears-0.0.5.ebuild')
-rw-r--r--net-mail/mailshears/mailshears-0.0.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-mail/mailshears/mailshears-0.0.5.ebuild b/net-mail/mailshears/mailshears-0.0.5.ebuild
new file mode 100644
index 000000000000..06a584f9a770
--- /dev/null
+++ b/net-mail/mailshears/mailshears-0.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ruby31 is ok too
+USE_RUBY="ruby26 ruby27 ruby30"
+
+# The tests are dangerous and shouldn't be run by anyone!
+# They mess with your local postgres databases.
+RUBY_FAKEGEM_RECIPE_TEST=none
+RUBY_FAKEGEM_RECIPE_DOC=yard
+RUBY_FAKEGEM_EXTRADOC="doc/${PN}.example.conf.yml"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mangle your mail garden"
+HOMEPAGE="http://michael.orlitzky.com/code/mailshears.xhtml"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/pg-1.2 <dev-ruby/pg-2"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman "doc/man1/${PN}.1"
+}