summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-05-14 12:00:15 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-05-14 12:00:57 +0200
commitae4301deed55caea1a6031852fa09eea60bd1c6a (patch)
tree2c84043c76e014b345d73668ea84e8304985b323 /net-mail/ytnef/ytnef-2.1.1.ebuild
parentwww-apps/owncloud: add 10.12.1 (diff)
downloadgentoo-ae4301deed55caea1a6031852fa09eea60bd1c6a.tar.gz
gentoo-ae4301deed55caea1a6031852fa09eea60bd1c6a.tar.bz2
gentoo-ae4301deed55caea1a6031852fa09eea60bd1c6a.zip
net-mail/ytnef: add 2.1.1
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-mail/ytnef/ytnef-2.1.1.ebuild')
-rw-r--r--net-mail/ytnef/ytnef-2.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-mail/ytnef/ytnef-2.1.1.ebuild b/net-mail/ytnef/ytnef-2.1.1.ebuild
new file mode 100644
index 000000000000..500dfe8510ff
--- /dev/null
+++ b/net-mail/ytnef/ytnef-2.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Yeraze's TNEF Stream Reader - for winmail.dat files"
+HOMEPAGE="https://github.com/Yeraze/ytnef"
+SRC_URI="https://github.com/Yeraze/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+QA_PKGCONFIG_VERSION="${PV}.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-devel/libtool"
+RDEPEND="dev-perl/MIME-tools"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}