summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-08-02 12:37:30 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-08-07 21:32:28 +0200
commit439e9a3498c34a6988246ae0877ccb2c6b810384 (patch)
treef4521152a5a2d133667a2c1424499eb5bd348e34 /net-mail
parentnet-libs/nodejs: sync live (diff)
downloadgentoo-439e9a3498c34a6988246ae0877ccb2c6b810384.tar.gz
gentoo-439e9a3498c34a6988246ae0877ccb2c6b810384.tar.bz2
gentoo-439e9a3498c34a6988246ae0877ccb2c6b810384.zip
net-mail/altermime: bump EAPI, fix pkgcheck issues
Signed-off-by: Filip Kobierski <fkobi@pm.me> Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/altermime/altermime-0.3.11-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-mail/altermime/altermime-0.3.11-r1.ebuild b/net-mail/altermime/altermime-0.3.11-r1.ebuild
new file mode 100644
index 000000000000..75771c4ff6bc
--- /dev/null
+++ b/net-mail/altermime/altermime-0.3.11-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="alterMIME is a small program which is used to alter your mime-encoded mailpacks"
+HOMEPAGE="https://pldaniels.com/altermime/"
+SRC_URI="https://www.pldaniels.com/altermime/${P}.tar.gz"
+
+LICENSE="Sendmail"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.10-MIME_headers-overflow.patch
+ "${FILESDIR}"/${P}-respect-flags.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin altermime
+ dodoc CHANGELOG README
+}