summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2018-01-05 11:08:14 -0500
committerMike Frysinger <vapier@gentoo.org>2018-01-05 11:14:45 -0500
commit9ccc108ae89ad9704f9d878af7aacfbb8713f6fd (patch)
tree335f13d96b99019cf3ac08bb89bbf729a5b3ef15 /net-misc/chrome-remote-desktop
parentsys-kernel/vanilla-sources: Version bumps for 4.4.X, 4.9.X and 4.14.X. (diff)
downloadgentoo-9ccc108ae89ad9704f9d878af7aacfbb8713f6fd.tar.gz
gentoo-9ccc108ae89ad9704f9d878af7aacfbb8713f6fd.tar.bz2
gentoo-9ccc108ae89ad9704f9d878af7aacfbb8713f6fd.zip
net-misc/chrome-remote-desktop: version bump to 63.0.3239.17
Diffstat (limited to 'net-misc/chrome-remote-desktop')
-rw-r--r--net-misc/chrome-remote-desktop/Manifest1
-rw-r--r--net-misc/chrome-remote-desktop/chrome-remote-desktop-63.0.3239.17.ebuild122
2 files changed, 123 insertions, 0 deletions
diff --git a/net-misc/chrome-remote-desktop/Manifest b/net-misc/chrome-remote-desktop/Manifest
index 41b671b6822c..4be0b9d9c9a1 100644
--- a/net-misc/chrome-remote-desktop/Manifest
+++ b/net-misc/chrome-remote-desktop/Manifest
@@ -2,3 +2,4 @@ DIST chrome-remote-desktop_49.0.2623.40_amd64.deb 20315570 BLAKE2B 03725450590fa
DIST chrome-remote-desktop_49.0.2623.40_i386.deb 20941574 BLAKE2B 7f86e734fdc9c95f8820912aa075d4be805896f4f045ba39fb1fedc9ba6e3b576d71ce67692f683009ff005c2c248ed067ef4980906ae9e158c107aa96b58470 SHA512 00cf6641ee993fb8c295ca99cb57cde42eb3dd6cc34ae4684f858279615695d5b1a257081e8988293f94e887986492e112bc0276f572cd592d9879dec88eace8
DIST chrome-remote-desktop_55.0.2883.50_amd64.deb 21636452 BLAKE2B 34ec5d7d5f01610161613921b685166be1f8c78eb8fdece45ea66fb83e05784adb33750fc9612cf77fd6a7b9c0bea8568c784d5b0ecd518e3f60ae2154295407 SHA512 3e140407d6e34caed18f3280d2136ea924ba7c9fc0159cde4981927be9c0bd090c58581ed01b3a99b8a796211500ff1588a847d5d3273ec814d9fb10285a97f8
DIST chrome-remote-desktop_57.0.2987.37_amd64.deb 15677362 BLAKE2B aa92ef2a6c89043ff7e1a39c186edc57dabd9b5a629391aa0603f51b527131a94cea501a9929a5cacd951b8204959ed93203b81bdadf677af5d937774d110f69 SHA512 df470d9f69545dd2793b5d97674bb8724f5ad3dfad05b4d5572b01a21443d79e6776fb72ca14044d7ee00660b7d040023c9716e2568551e2862bdfd3cff99d88
+DIST chrome-remote-desktop_63.0.3239.17_amd64.deb 19026074 BLAKE2B 9a62d317768d6c0ab3cf3c6e7c5dea074133cc7c5d2b04ffdc1e0f9877f5f606c044ebab7b230914eba2ade51d2805fb1267f7b1731fa36235495a8192eb3c48 SHA512 2843deb7817217c8b8e41931b1e9ef0fdfb40c6a4ceb1bc69499aed16cc729d7ed64f88200c9bb2366a768f294a164da2360ed2b9654d1626696bcf0403e347a
diff --git a/net-misc/chrome-remote-desktop/chrome-remote-desktop-63.0.3239.17.ebuild b/net-misc/chrome-remote-desktop/chrome-remote-desktop-63.0.3239.17.ebuild
new file mode 100644
index 000000000000..16151ff33c63
--- /dev/null
+++ b/net-misc/chrome-remote-desktop/chrome-remote-desktop-63.0.3239.17.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Base URL: https://dl.google.com/linux/chrome-remote-desktop/deb/
+# Fetch the Release file:
+# https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/Release
+# Which gives you the Packages file:
+# https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-i386/Packages
+# https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-amd64/Packages
+# And finally gives you the file name:
+# pool/main/c/chrome-remote-desktop/chrome-remote-desktop_29.0.1547.32_amd64.deb
+#
+# Use curl to find the answer:
+# curl -q https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-amd64/Packages | grep ^Filename
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+PLOCALES="am ar bg bn ca cs da de el en_GB en es_419 es et fa fil fi fr gu he hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt_BR pt_PT ro ru sk sl sr sv sw ta te th tr uk vi zh_CN zh_TW"
+
+inherit unpacker eutils python-single-r1 l10n
+
+DESCRIPTION="access remote computers via Chrome!"
+PLUGIN_URL="https://chrome.google.com/remotedesktop"
+HOMEPAGE="https://support.google.com/chrome/answer/1649523 ${PLUGIN_URL}"
+BASE_URI="https://dl.google.com/linux/chrome-remote-desktop/deb/pool/main/c/${PN}/${PN}_${PV}"
+SRC_URI="amd64? ( ${BASE_URI}_amd64.deb )"
+
+LICENSE="google-chrome"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# All the libs this package links against.
+RDEPEND="app-admin/sudo
+ ${PYTHON_DEPS}
+ >=dev-libs/expat-2
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ dev-python/psutil
+ gnome-base/gconf:2
+ media-libs/fontconfig
+ media-libs/freetype:2
+ sys-devel/gcc
+ sys-libs/glibc
+ sys-libs/pam
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXtst
+ x11-libs/pango"
+# Settings we just need at runtime.
+# TODO: Look at switching to xf86-video-dummy & xf86-input-void instead of xvfb.
+RDEPEND+="
+ x11-base/xorg-server[xvfb]"
+DEPEND=""
+
+S=${WORKDIR}
+
+QA_PREBUILT="/opt/google/chrome-remote-desktop/*"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-44.0.2403.44-always-sudo.patch #541708
+ cd opt/google/chrome-remote-desktop
+ python_fix_shebang chrome-remote-desktop
+
+ cd remoting_locales
+ rm fake-bidi* || die
+ PLOCALES=${PLOCALES//_/-} l10n_find_plocales_changes "${PWD}" '' '.pak'
+}
+
+src_install() {
+ pushd opt/google/chrome-remote-desktop/remoting_locales >/dev/null || die
+ rm_pak() { local l=${1//_/-}; rm "${l}.pak" "${l}.pak.info"; }
+ l10n_for_each_disabled_locale_do rm_pak
+ popd >/dev/null
+
+ insinto /etc
+ doins -r etc/opt
+
+ insinto /opt
+ doins -r opt/google
+ chmod a+rx "${ED}"/opt/google/${PN}/* || die
+ fperms +s /opt/google/${PN}/user-session
+
+ dodir /etc/pam.d
+ dosym system-remote-login /etc/pam.d/${PN}
+
+ dodoc usr/share/doc/${PN}/changelog*
+
+ newinitd "${FILESDIR}"/${PN}.rc ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Two ways to launch the server:"
+ elog "(1) access an existing desktop"
+ elog " (a) install the Chrome plugin on the server & client:"
+ elog " ${PLUGIN_URL}"
+ elog " (b) on the server, run the Chrome plugin & enable remote access"
+ elog " (c) on the client, connect to the server"
+ elog "(2) headless system"
+ elog " (a) install the Chrome plugin on the client:"
+ elog " ${PLUGIN_URL}"
+ elog " (b) run ${EPREFIX}opt/google/chrome-remote-desktop/start-host --help to get the auth URL"
+ elog " (c) when it redirects you to a blank page, look at the URL for a code=XXX field"
+ elog " (d) run start-host again, and past the code when asked for an authorization code"
+ elog " (e) on the client, connect to the server"
+ elog
+ elog "Configuration settings you might want to be aware of:"
+ elog " ~/.${PN}-session - shell script to start your session"
+ elog " /etc/init.d/${PN} - script to auto-restart server"
+ fi
+}