summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-14 03:24:14 +0000
committerSam James <sam@gentoo.org>2022-11-14 03:48:10 +0000
commitc02869eecf10098e7a8622a95448f0cc9d973ac0 (patch)
tree980289db4c6db6132bd716baec7669cf09bd2c40 /net-misc/chrony
parentdev-libs/libpipeline: add 1.5.7 (diff)
downloadgentoo-c02869eecf10098e7a8622a95448f0cc9d973ac0.tar.gz
gentoo-c02869eecf10098e7a8622a95448f0cc9d973ac0.tar.bz2
gentoo-c02869eecf10098e7a8622a95448f0cc9d973ac0.zip
net-misc/chrony: drop obsolete readline dep
chrony no longer supports GNU readline and only supports libedit for 'readline-like functionality'. The USE flag 'readline' is now used to control the libedit dependency and the functionality it provides, because 'readline' is the feature and it's the most common name for that type of functionality. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/chrony-9999.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index f8e842d67fb0..dc5eee61c6d2 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -27,7 +27,7 @@ S="${WORKDIR}/${P/_/-}"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+caps +cmdmon debug html ipv6 libedit libtomcrypt +nettle nss +ntp +nts +phc pps +refclock +rtc samba +seccomp +sechash selinux"
+IUSE="+caps +cmdmon debug html ipv6 libtomcrypt +nettle nss +ntp +nts +phc pps +readline +refclock +rtc samba +seccomp +sechash selinux"
# nettle > nss > libtomcrypt in configure
REQUIRED_USE="
sechash? ( || ( nettle nss libtomcrypt ) )
@@ -44,12 +44,11 @@ DEPEND="
acct-user/ntp
sys-libs/libcap
)
- libedit? ( dev-libs/libedit )
- !libedit? ( sys-libs/readline:= )
nettle? ( dev-libs/nettle:= )
nss? ( dev-libs/nss:= )
nts? ( net-libs/gnutls:= )
pps? ( net-misc/pps-tools )
+ readline? ( dev-libs/libedit )
seccomp? ( sys-libs/libseccomp )
"
RDEPEND="
@@ -68,7 +67,10 @@ BDEPEND="
if [[ ${PV} == 9999 ]] ; then
# Needed for doc generation in 9999
REQUIRED_USE+=" html"
- BDEPEND+=" virtual/w3m"
+ BDEPEND+="
+ sys-devel/bison
+ virtual/w3m
+ "
else
BDEPEND+=" verify-sig? ( >=sec-keys/openpgp-keys-mlichvar-20210513 )"
fi
@@ -115,7 +117,12 @@ src_configure() {
$(usex cmdmon '' '--disable-cmdmon')
$(usex debug '--enable-debug' '')
$(usex ipv6 '' '--disable-ipv6')
- $(usex libedit '' '--without-editline')
+
+ # USE=readline here means "readline-like functionality"
+ # chrony only supports libedit in terms of the library providing
+ # it.
+ $(usex readline '' '--without-editline --disable-readline')
+
$(usex libtomcrypt '' '--without-tomcrypt')
$(usex nettle '' '--without-nettle')
$(usex nss '' '--without-nss')