summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/dnetstats
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/dnetstats')
-rw-r--r--net-misc/dnetstats/Manifest1
-rw-r--r--net-misc/dnetstats/dnetstats-1.2.6-r3.ebuild52
-rw-r--r--net-misc/dnetstats/files/org.gentoo.pkexec.dnetstats.policy17
-rw-r--r--net-misc/dnetstats/metadata.xml6
4 files changed, 76 insertions, 0 deletions
diff --git a/net-misc/dnetstats/Manifest b/net-misc/dnetstats/Manifest
new file mode 100644
index 000000000000..a28ea6dff1a5
--- /dev/null
+++ b/net-misc/dnetstats/Manifest
@@ -0,0 +1 @@
+DIST 107467-DNetStats-v1.2.6-release.tar.bz2 213492 SHA256 590521d60731e7066855151c4a9545322c8f6031aaec766fae4ad19a6a95cb57 SHA512 80fd7c296fba6921d23b22524de3a05e19f44113c57a43b615f963c84d7587ef7c187c3d7d410b3919f536e2bf9708aec6022e63c298bbc8790d5577bb783b68 WHIRLPOOL 1c82da70668f47af2db0f5901805966bf3e7972dd8a2a7a45daa1e37f757bb64521482132eef7d3fbd3d194fc05cd59d44e6b04446b09b05d3c54d5533c5af37
diff --git a/net-misc/dnetstats/dnetstats-1.2.6-r3.ebuild b/net-misc/dnetstats/dnetstats-1.2.6-r3.ebuild
new file mode 100644
index 000000000000..0f83b478e96e
--- /dev/null
+++ b/net-misc/dnetstats/dnetstats-1.2.6-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils qt4-r2
+
+MY_PN="DNetStats"
+MY_P="${MY_PN}-v${PV}-release"
+
+DESCRIPTION="Qt4 network monitor utility"
+HOMEPAGE="http://qt-apps.org/content/show.php/DNetStats?content=107467"
+SRC_URI="http://qt-apps.org/CONTENT/content-files/107467-${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="policykit"
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+RDEPEND="${DEPEND}
+ policykit? ( sys-auth/polkit )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ # clueless upstream ships generated files...
+ rm -rf moc_* qrc_* || die
+}
+
+src_install() {
+ newbin mythread ${PN}
+ dodoc ReadMe
+
+ newicon resource/energy.png ${PN}.png
+ make_desktop_entry ${PN} DNetStats ${PN} 'Qt;Network;Dialup'
+
+ if use policykit; then
+ insinto /usr/share/polkit-1/actions
+ doins "${FILESDIR}/org.gentoo.pkexec.${PN}.policy"
+ sed -i -e 's/^Exec=/&pkexec /' \
+ "${ED}"usr/share/applications/${PN}*.desktop \
+ || die
+ fi
+}
diff --git a/net-misc/dnetstats/files/org.gentoo.pkexec.dnetstats.policy b/net-misc/dnetstats/files/org.gentoo.pkexec.dnetstats.policy
new file mode 100644
index 000000000000..c910a6c3610b
--- /dev/null
+++ b/net-misc/dnetstats/files/org.gentoo.pkexec.dnetstats.policy
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE policyconfig PUBLIC "-//freedesktop//DTD polkit Policy Configuration 1.0//EN"
+ "http://www.freedesktop.org/software/polkit/policyconfig-1.dtd">
+<policyconfig>
+ <vendor>Gentoo</vendor>
+ <vendor_url>http://www.gentoo.org/</vendor_url>
+ <action id="org.gentoo.pkexec.dnetstats">
+ <message>Authentication is required to run the DNetStats</message>
+ <defaults>
+ <allow_any>auth_admin</allow_any>
+ <allow_inactive>auth_admin</allow_inactive>
+ <allow_active>auth_admin</allow_active>
+ </defaults>
+ <annotate key="org.freedesktop.policykit.exec.path">/usr/bin/dnetstats</annotate>
+ <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
+ </action>
+</policyconfig>
diff --git a/net-misc/dnetstats/metadata.xml b/net-misc/dnetstats/metadata.xml
new file mode 100644
index 000000000000..46f151f3da59
--- /dev/null
+++ b/net-misc/dnetstats/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+</pkgmetadata>
+