summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-01-12 13:29:19 +0100
committerMatthias Maier <tamiko@gentoo.org>2016-01-12 14:35:34 +0100
commitb69cff032b80ed6ad87c8c17603179031c61f63e (patch)
tree5d0ea92716f4654228cff9fc4427ec4d76d92b54 /net-misc/libteam/libteam-1.22.ebuild
parentapp-emulation/xen: rm vulnerable vns. 4.6.0-r{3,4} (diff)
downloadgentoo-b69cff032b80ed6ad87c8c17603179031c61f63e.tar.gz
gentoo-b69cff032b80ed6ad87c8c17603179031c61f63e.tar.bz2
gentoo-b69cff032b80ed6ad87c8c17603179031c61f63e.zip
net-misc/libteam: bump to version 1.22, bug 566934
This also resolves the compilation issue with dev-libs/libnl-3.2.27 Gentoo-Bugs: 566934 568542 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/libteam/libteam-1.22.ebuild')
-rw-r--r--net-misc/libteam/libteam-1.22.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/libteam/libteam-1.22.ebuild b/net-misc/libteam/libteam-1.22.ebuild
new file mode 100644
index 000000000000..1a7781399c59
--- /dev/null
+++ b/net-misc/libteam/libteam-1.22.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils linux-info
+
+DESCRIPTION="Library and tools set for controlling team network device"
+HOMEPAGE="http://libteam.org"
+SRC_URI="http://libteam.org/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="dbus debug examples static-libs +syslog zmq"
+
+DEPEND=">=dev-libs/jansson-2.4
+ dev-libs/libdaemon
+ >=dev-libs/libnl-3.2.19[utils]
+ dbus? ( sys-apps/dbus )
+ zmq? ( >=net-libs/zeromq-3.2.0 )
+ "
+
+RDEPEND="${DEPEND}
+ syslog? ( virtual/logger )"
+
+CONFIG_CHECK="~NET_TEAM ~NET_TEAM_MODE_ROUNDROBIN ~NET_TEAM_MODE_ACTIVEBACKUP ~NET_TEAM_MODE_BROADCAST ~NET_TEAM_MODE_RANDOM ~NET_TEAM_MODE_LOADBALANCE"
+ERROR_NET_TEAM="NET_TEAM is not enabled in this kernel!
+Only >=3.3.0 kernel version support in team mode"
+
+DOCS=( README )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable syslog logging)
+ $(use_enable dbus)
+ $(use_enable zmq)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ insinto /etc/dbus-1/system.d
+ doins teamd/dbus/teamd.conf
+
+ if use examples; then
+ docinto examples
+ dodoc teamd/example_configs/*
+ fi
+}