summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-01-29 09:52:05 -0500
committerCraig Andrews <candrews@gentoo.org>2021-01-29 09:53:01 -0500
commit0ba7bdbf3ea3e566e3e818972996fd5b91c05c6d (patch)
tree8d4cead01fc1268f275b973b5d94c6721918a99e /net-misc/proxytunnel
parentdev-libs/libgcrypt: add CPU_FLAGS_* (diff)
downloadgentoo-0ba7bdbf3ea3e566e3e818972996fd5b91c05c6d.tar.gz
gentoo-0ba7bdbf3ea3e566e3e818972996fd5b91c05c6d.tar.bz2
gentoo-0ba7bdbf3ea3e566e3e818972996fd5b91c05c6d.zip
net-misc/proxytunnel: 1.10.20210128 version bump
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-misc/proxytunnel')
-rw-r--r--net-misc/proxytunnel/Manifest1
-rw-r--r--net-misc/proxytunnel/proxytunnel-1.10.20210128.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/proxytunnel/Manifest b/net-misc/proxytunnel/Manifest
index ef12592d2ee5..b607a10d8683 100644
--- a/net-misc/proxytunnel/Manifest
+++ b/net-misc/proxytunnel/Manifest
@@ -1 +1,2 @@
DIST proxytunnel-1.10.20200907.tar.gz 54711 BLAKE2B 79b5fc459ece793997b4407679498af29c53aa495802259f95ec600665fca815f9e43cafcbf1d0407c4f7184c21e7dae3f899413dbeeaf0924034e1bbd26cddb SHA512 f04570e87a0fda024661135b6598f87f1d7407c368fe3453300a655fefedb66ade96a742223de08b500ba9fc1fdc2e6519005ea38529ceaa3c1815f5012fca84
+DIST proxytunnel-1.10.20210128.tar.gz 54702 BLAKE2B e873f20c37b5c0dc66a2a6767cfb8d9f73e7cfceaf99e03750eb5fd72acd33bd42281c2eec7e1a72ccecdd7fcd62c8592926c55c206aad220ed5b0b9bc3d357e SHA512 188ab239362cc7c9fd05ddaeaa85aee45c9040ac8f39f10cd0a97c2b92f49a9f5b854690b945109474492955c46b1f5c87e3251bfe68b22d3f1b3a21cf17eda0
diff --git a/net-misc/proxytunnel/proxytunnel-1.10.20210128.ebuild b/net-misc/proxytunnel/proxytunnel-1.10.20210128.ebuild
new file mode 100644
index 000000000000..e15bad2afce3
--- /dev/null
+++ b/net-misc/proxytunnel/proxytunnel-1.10.20210128.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Connect stdin and stdout to a server via an HTTPS proxy"
+HOMEPAGE="https://github.com/proxytunnel/proxytunnel/ https://proxytunnel.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static"
+
+RDEPEND="dev-libs/openssl:="
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ "
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CHANGES CREDITS INSTALL.md KNOWN_ISSUES LICENSE.txt README.md RELNOTES TODO )
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+src_prepare() {
+ default
+ sed -i -e 's/libssl/libssl libcrypto/' Makefile || die "Sed failed!"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake install prefix="${EPREFIX}"/usr DESTDIR="${D}"
+ einstalldocs
+}