summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-12-30 14:48:17 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2019-12-30 14:57:27 +0100
commit138392a1abb7041dd9dd228c49c33c6daca4347a (patch)
treebbe4bf00c5cca95c0b1d96aaca69bb61282f2dd1 /net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild
parentnet-misc/python-x2go: 0.6.1.2 bump (diff)
downloadgentoo-138392a1abb7041dd9dd228c49c33c6daca4347a.tar.gz
gentoo-138392a1abb7041dd9dd228c49c33c6daca4347a.tar.bz2
gentoo-138392a1abb7041dd9dd228c49c33c6daca4347a.zip
net-misc/pyhoca-cli: 0.6.1.2 bump
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild')
-rw-r--r--net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild b/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild
new file mode 100644
index 000000000000..30c368003023
--- /dev/null
+++ b/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="X2Go command line client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]
+ >=net-misc/python-x2go-0.6.1.1[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install() {
+ distutils-r1_python_install
+ python_doscript ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/man1/*
+ find "${ED}" -name '*.pth' -delete || die
+}