summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-12-30 11:39:24 +0100
committerFabian Groffen <grobian@gentoo.org>2021-12-30 11:39:35 +0100
commit883377500a40fca29a1b47eaf25eb8879e340833 (patch)
tree6653e383fccd068eed852f6ce7e34768a38fc60b /net-misc/rsync/rsync-3.2.3-r5.ebuild
parentapp-crypt/sequoia-sq: initial import (diff)
downloadgentoo-883377500a40fca29a1b47eaf25eb8879e340833.tar.gz
gentoo-883377500a40fca29a1b47eaf25eb8879e340833.tar.bz2
gentoo-883377500a40fca29a1b47eaf25eb8879e340833.zip
net-misc/rsync-3.2.3-r5: fix IPv6 support using musl
Closes: https://bugs.gentoo.org/609694 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'net-misc/rsync/rsync-3.2.3-r5.ebuild')
-rw-r--r--net-misc/rsync/rsync-3.2.3-r5.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-misc/rsync/rsync-3.2.3-r5.ebuild b/net-misc/rsync/rsync-3.2.3-r5.ebuild
index 684a8e105cd7..7f996c540050 100644
--- a/net-misc/rsync/rsync-3.2.3-r5.ebuild
+++ b/net-misc/rsync/rsync-3.2.3-r5.ebuild
@@ -10,7 +10,7 @@ fi
WANT_LIBTOOL=none
-inherit autotools prefix systemd
+inherit autotools flag-o-matic prefix systemd
DESCRIPTION="File transfer program to keep remote files into sync"
HOMEPAGE="https://rsync.samba.org/"
@@ -47,6 +47,10 @@ src_prepare() {
}
src_configure() {
+ # Force enable IPv6 on musl - upstream bug:
+ # https://bugzilla.samba.org/show_bug.cgi?id=10715
+ use elibc_musl && use ipv6 && append-cppflags -DINET6
+
local myeconfargs=(
--with-rsyncd-conf="${EPREFIX}"/etc/rsyncd.conf
--without-included-popt