summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 22:24:33 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:27 +0100
commit18e55fb092a6ddd4a747beabacf11a635a8b9064 (patch)
treeb4786609be0a12eb95b9e5d4e4eeb1594a2dfac3 /net-misc/sntpd
parentnet-misc/mcproxy: drop 1.1.1-r1 (diff)
downloadgentoo-18e55fb092a6ddd4a747beabacf11a635a8b9064.tar.gz
gentoo-18e55fb092a6ddd4a747beabacf11a635a8b9064.tar.bz2
gentoo-18e55fb092a6ddd4a747beabacf11a635a8b9064.zip
net-misc/sntpd: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc/sntpd')
-rw-r--r--net-misc/sntpd/sntpd-3.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/sntpd/sntpd-3.0-r2.ebuild b/net-misc/sntpd/sntpd-3.0-r2.ebuild
new file mode 100644
index 000000000000..f7b2bb80a6a1
--- /dev/null
+++ b/net-misc/sntpd/sntpd-3.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="A NTP (RFC-1305 and RFC-4330) client and server for unix-alike systems"
+HOMEPAGE="https://github.com/troglobit/sntpd"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86"
+IUSE="adjtimex systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with adjtimex)
+ $(use_with systemd systemd $(systemd_get_systemunitdir))
+ --with-ntpclient
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/sntpd.initd-r1 sntpd
+ newconfd "${FILESDIR}"/sntpd.confd sntpd
+}