summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-08-06 05:26:12 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-08-06 05:26:19 -0400
commitfbd9798a0aa98c28dea3a7c7cedf22113e94a9c6 (patch)
tree8632edc14dd7bbbe2729b9ca2e9e7b1427e33769 /net-misc
parentnet-misc/yt-dlp: drop 2024.07.16, 2024.07.25 (diff)
downloadgentoo-fbd9798a0aa98c28dea3a7c7cedf22113e94a9c6.tar.gz
gentoo-fbd9798a0aa98c28dea3a7c7cedf22113e94a9c6.tar.bz2
gentoo-fbd9798a0aa98c28dea3a7c7cedf22113e94a9c6.zip
net-misc/yt-dlp: add 2024.08.06
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2024.08.06.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index ae1144f3ea75..5c447042bd92 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1 +1,2 @@
DIST yt-dlp-2024.08.01.tar.gz 5708569 BLAKE2B 83659efb7de95792e28edd8f43103c73141ffb9e3492baaf3533759329e36f8fc84da5a45a281ca394664a67c0723019de89f43362c24ff026c4cdd6158f04b5 SHA512 e454969e641f2e36cf1deae142a0eddfb54eb9dc19601066e129d597304cb28550b08b2a5923e7ebf7133e7793fcd6b3006d7b19040f37d40450854f4fe06247
+DIST yt-dlp-2024.08.06.tar.gz 5710396 BLAKE2B ba657ddd054fc814adfc9644378ab51e50f980a8ce9d9589d0e69d4242fc68a22314a230135c54737a1b453d853d811a48d1737b05c2e04d3494ca580a6937b0 SHA512 5db3ceeb217148755e31492d490bfeb69879400873274dec4320ce58b49dce9ce93d1e32714d6b7433364780e269087fc55acb94ef4fca0d998c504f2efac41f
diff --git a/net-misc/yt-dlp/yt-dlp-2024.08.06.ebuild b/net-misc/yt-dlp/yt-dlp-2024.08.06.ebuild
new file mode 100644
index 000000000000..a4bd878780a8
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2024.08.06.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="
+ https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="Unlicense"
+SLOT="0"
+# note that yt-dlp bumps are typically done straight-to-stable (unless there
+# was major/breaking changes) given website changes breaks it on a whim
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust pycryptodome and drop optional dependencies (bug #828466)
+ sed -Ei pyproject.toml \
+ -e 's/("pycryptodome)x/\1/' \
+ -e '/"(brotli.*|certifi|mutagen|requests|urllib3|websockets)/d' || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails with FEATURES=network-sandbox
+ test/test_networking.py::TestHTTPRequestHandler::test_connect_timeout
+ # fails with FEATURES=distcc, bug #915614
+ test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
+ )
+
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+ optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}