summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2023-01-08 22:29:53 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2023-01-08 22:30:18 +0100
commit5fa93e66fca2460c38e396a726a85559c7158f6b (patch)
tree1a703e6afd6e71b9f3a6edcb4069cb4267573dd6 /net-p2p
parentdev-util/bcc: remove unused patch (diff)
downloadgentoo-5fa93e66fca2460c38e396a726a85559c7158f6b.tar.gz
gentoo-5fa93e66fca2460c38e396a726a85559c7158f6b.tar.bz2
gentoo-5fa93e66fca2460c38e396a726a85559c7158f6b.zip
net-p2p/nicotine+: 3.2.8 version bump
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/nicotine+/Manifest1
-rw-r--r--net-p2p/nicotine+/nicotine+-3.2.8.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-p2p/nicotine+/Manifest b/net-p2p/nicotine+/Manifest
index 176860f5f248..755b39dfd969 100644
--- a/net-p2p/nicotine+/Manifest
+++ b/net-p2p/nicotine+/Manifest
@@ -1,3 +1,4 @@
DIST nicotine+-3.2.2.tar.gz 2868677 BLAKE2B d066f6ca54af627eb20a6bd76db57ece77ce00ca084d7f70efb7168a786a2666121126dc6e62ec9eddebf28ba370e5768a3e771f4ea34cf2073e782b8b74d8e0 SHA512 e8e28b7452a31b7221135e145eb7ee91e30a927a4dbf42bafa7d3380835f2cde4cbf28adc77041b80b6bc4d20d7a5e37043822933468e81dc9ca3458b152666d
DIST nicotine+-3.2.5.tar.gz 2966816 BLAKE2B d42c8a7d253a7b58c414f67a0abd67c6ecd7523e0ec0b649275751a34c661a49b01ff67578cbd37af74c68696cd0afe9b0ee8a184172ad3f2b5a29d655d956cf SHA512 a71d096e7a77c0e147cb5b3d62d194967ae903fb6263b8fcb0819c67ab551fdb72be72326223d846e9584db97a22afc721b695205c26d79d579c6fe957d20644
DIST nicotine+-3.2.6.tar.gz 2969850 BLAKE2B c5a0aa43ffc8730338107da7b7cd8b60350b0976b3d81cdbc383b7c0eb22e773e71120695631d21eb8b2ad2a05c12484559bd37b8e8ca0d6d8139331be54be54 SHA512 2f807bf6bda731dac82b45cbfb161462a6430bd6e7c558ed97cdb5e6eb8c9151dfa7bb319e07d3e5d71cbb72012cf3ded33747e94269b86093ca51a05b1d0cb7
+DIST nicotine+-3.2.8.tar.gz 2984416 BLAKE2B 8ca996e67a296535a158d1929579c4f479630bf4b666b53e91939fd61dcac90de657bfccd30521da9cc4468f3beecf1be433790ca711c67d0cf6d1e0a901be90 SHA512 92298b97ce34d713b0a4626602757a9215b57a0c3ac00c2845ff66597f0a361243f47c8abf3e8548f9f8c1829e56eb036e202242340bf268bf008b6ad6d016a5
diff --git a/net-p2p/nicotine+/nicotine+-3.2.8.ebuild b/net-p2p/nicotine+/nicotine+-3.2.8.ebuild
new file mode 100644
index 000000000000..66c30e2034be
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-3.2.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="https://github.com/Nicotine-Plus/nicotine-plus"
+SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ ${DEPEND}
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/nicotine-plus-${PV}"
+
+EPYTEST_IGNORE=(
+ "test/integration/test_startup.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}