summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-12-10 15:44:35 +0000
committerJames Le Cuirot <chewi@gentoo.org>2023-12-10 15:45:48 +0000
commitb3890a1d61988c4def6c678fea1409b6ffffd79e (patch)
treeff5bc6b475dbb3565e890606a2db4c457ff6611a /net-print/hplip-plugin
parentdev-util/scons: Deselect test broken on ppc64 (apparently) (diff)
downloadgentoo-b3890a1d61988c4def6c678fea1409b6ffffd79e.tar.gz
gentoo-b3890a1d61988c4def6c678fea1409b6ffffd79e.tar.bz2
gentoo-b3890a1d61988c4def6c678fea1409b6ffffd79e.zip
net-print/hplip-plugin: Version bump to 3.23.12
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'net-print/hplip-plugin')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.23.12.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index d1079c1e309b..738b86d26156 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1 +1,2 @@
+DIST hplip-3.23.12-plugin.run 11491524 BLAKE2B 9b87522a78588d65815992a170451888b4c6ac83809498fae01cfa4d2c333657a7cf49f2358e12ebfd0ae0f4169e29729e9ef8ba6716f74de0a83b11552275e3 SHA512 933c27040443584e0cfda71b50b8a251ebd34fdf4a2c90f40e36d1c155b3ae87c1474835356f685de2997469b4b7a3f000e216fd427118eea2542fa142783ab9
DIST hplip-3.23.8-plugin.run 11491257 BLAKE2B 1e87b741ebb28605c18954033e5b34ce2456671786e5472665e307253121635c23ecb920f974042ddbf8ebe76882d810f1fce2d39a46fadf774048f9a5673b33 SHA512 ba27bb609d2c17972bc7506ca6e9ef8c389c764c8276d0b1ddd711254f9bdb5c354ebe05026e392bfc261648fc57ccf199f60403c0bfbc3aceb78fcf890a39db
diff --git a/net-print/hplip-plugin/hplip-plugin-3.23.12.ebuild b/net-print/hplip-plugin/hplip-plugin-3.23.12.ebuild
new file mode 100644
index 000000000000..4bf67bc6bda1
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.23.12.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+S="${WORKDIR}"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="orblite"
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+ orblite? (
+ media-gfx/sane-backends
+ >=sys-libs/glibc-2.26
+ virtual/libusb:0
+ )
+"
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+src_install() {
+ local hplip_arch plugin
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ arm64) hplip_arch="arm64" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ bb_orblite-*)
+ use orblite || continue
+ plugin_type=scan ;;
+ bb_*)
+ plugin_type=scan ;;
+ fax_*)
+ plugin_type=fax ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}