summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2020-04-24 11:16:29 +0200
committerChristian Ruppert <idl0r@gentoo.org>2020-04-24 11:16:55 +0200
commitf1221ed5ec25c2d86b99860d07c2d1b047d6beb5 (patch)
tree2f51d90ba47860783074ed89d7783de62bc1d66e /net-proxy/haproxy/haproxy-2.0.9999.ebuild
parentnet-proxy/haproxy: add revision with GLEP81 group/user packages (diff)
downloadgentoo-f1221ed5ec25c2d86b99860d07c2d1b047d6beb5.tar.gz
gentoo-f1221ed5ec25c2d86b99860d07c2d1b047d6beb5.tar.bz2
gentoo-f1221ed5ec25c2d86b99860d07c2d1b047d6beb5.zip
net-proxy/haproxy: GLEP 81 accts, #701218. Thanks to Tomáš Mózes
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Christian Ruppert <idl0r@gentoo.org>
Diffstat (limited to 'net-proxy/haproxy/haproxy-2.0.9999.ebuild')
-rw-r--r--net-proxy/haproxy/haproxy-2.0.9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/net-proxy/haproxy/haproxy-2.0.9999.ebuild b/net-proxy/haproxy/haproxy-2.0.9999.ebuild
index 06e10c936692..7e2cb38725c6 100644
--- a/net-proxy/haproxy/haproxy-2.0.9999.ebuild
+++ b/net-proxy/haproxy/haproxy-2.0.9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit user toolchain-funcs flag-o-matic systemd linux-info $SCM
+inherit toolchain-funcs flag-o-matic systemd linux-info $SCM
MY_P="${PN}-${PV/_beta/-dev}"
@@ -45,7 +45,9 @@ DEPEND="
zlib? ( sys-libs/zlib )
lua? ( dev-lang/lua:5.3 )
device-atlas? ( dev-libs/device-atlas-api-c )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ acct-group/haproxy
+ acct-user/haproxy"
S="${WORKDIR}/${MY_P}"
@@ -63,9 +65,6 @@ haproxy_use() {
}
pkg_setup() {
- enewgroup haproxy
- enewuser haproxy -1 -1 -1 haproxy
-
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup