summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan-Espen Oversand <sigsegv@radiotube.org>2023-06-10 23:14:06 +0200
committerSam James <sam@gentoo.org>2023-06-10 22:36:33 +0100
commitce94e4574d13d9a3bdd78114d9df75a938ad62d4 (patch)
tree644b73c29d33996cb2eea47580f48acdae4bbeb1 /net-vpn
parentnet-vpn/vtun: drop 3.0.4-r2 (diff)
downloadgentoo-ce94e4574d13d9a3bdd78114d9df75a938ad62d4.tar.gz
gentoo-ce94e4574d13d9a3bdd78114d9df75a938ad62d4.tar.bz2
gentoo-ce94e4574d13d9a3bdd78114d9df75a938ad62d4.zip
net-vpn/vtun: add 3.0.4-r4
explicit bdep bison due to using extension features Closes: https://bugs.gentoo.org/907988 Signed-off-by: Jan-Espen Oversand <sigsegv@radiotube.org> Closes: https://github.com/gentoo/gentoo/pull/31379 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/vtun/files/vtun-3.0.4-use-bison-for-yacc.patch40
-rw-r--r--net-vpn/vtun/vtun-3.0.4-r4.ebuild62
2 files changed, 102 insertions, 0 deletions
diff --git a/net-vpn/vtun/files/vtun-3.0.4-use-bison-for-yacc.patch b/net-vpn/vtun/files/vtun-3.0.4-use-bison-for-yacc.patch
new file mode 100644
index 000000000000..40c934c7ea81
--- /dev/null
+++ b/net-vpn/vtun/files/vtun-3.0.4-use-bison-for-yacc.patch
@@ -0,0 +1,40 @@
+--- a/configure.in 2016-10-01 23:46:01.000000000 +0200
++++ b/configure.in 2023-06-10 22:44:20.873592074 +0200
+@@ -82,11 +82,14 @@
+ AC_CANONICAL_SYSTEM
+
+ dnl Check for programs.
+-AC_PROG_YACC
+ AC_PROG_LEX
+ AC_PROG_CC
+ AC_PROG_INSTALL
+
++AC_ARG_VAR([BISON], [bison command for yacc parsing])
++AC_CHECK_PROG([BISON], [bison -y], [bison -y], [no])
++AS_IF([test "x$BISON" = "xno"], [AC_MSG_ERROR([bison not found])])
++
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+ AC_C_INLINE
+--- a/Makefile.in 2016-10-01 23:46:00.000000000 +0200
++++ b/Makefile.in 2023-06-10 23:00:25.278904190 +0200
+@@ -21,8 +21,8 @@
+ CFLAGS = @CFLAGS@ @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@ @LIBS@
+
+-YACC = @YACC@
+-YACCFLAGS = -d
++BISON = @BISON@
++BISONFLAGS = -d
+
+ LEX = @LEX@
+ LEXFLAGS = -t
+@@ -62,7 +62,7 @@
+ $(CC) $(CFLAGS) -o vtund $(OBJS) $(LFD_OBJS) $(LDFLAGS)
+
+ cfg_file.tab.h:
+- $(YACC) $(YACCFLAGS) -b cfg_file cfg_file.y
++ $(BISON) $(BISONFLAGS) -b cfg_file cfg_file.y
+
+ cfg_file.tab.c: cfg_file.y cfg_kwords.h config.h cfg_file.tab.h
+
diff --git a/net-vpn/vtun/vtun-3.0.4-r4.ebuild b/net-vpn/vtun/vtun-3.0.4-r4.ebuild
new file mode 100644
index 000000000000..81eaa36bd9e3
--- /dev/null
+++ b/net-vpn/vtun/vtun-3.0.4-r4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info autotools
+
+DESCRIPTION="Create tunnels over TCP/IP networks with shaping, encryption, and compression"
+SRC_URI="https://sourceforge.net/projects/vtun/files/${PN}/${PV}/${P}.tar.gz"
+HOMEPAGE="https://vtun.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="lzo socks5 ssl zlib"
+
+RDEPEND="
+ lzo? ( dev-libs/lzo:2 )
+ socks5? ( net-proxy/dante )
+ ssl? ( dev-libs/openssl:0= )
+ zlib? ( sys-libs/zlib )
+ dev-libs/libbsd"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/lex
+ sys-devel/bison
+"
+
+DOCS=( ChangeLog Credits FAQ README README.Setup README.Shaper TODO )
+CONFIG_CHECK="~TUN"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libssl-ctx.patch
+ "${FILESDIR}"/${P}-includes.patch
+ "${FILESDIR}"/${P}-naughty-inlines.patch
+ "${FILESDIR}"/${P}-autoconf-fork-not-working.patch
+ "${FILESDIR}"/${P}-use-bison-for-yacc.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+ sed -i -e '/^LDFLAGS/s|=|+=|g' Makefile.in || die
+ sed -i 's:$(BIN_DIR)/strip $(DESTDIR)$(SBIN_DIR)/vtund::' Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable ssl) \
+ $(use_enable zlib) \
+ $(use_enable lzo) \
+ $(use_enable socks5 socks) \
+ --enable-shaper
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/vtun.rc vtun
+ insinto /etc
+ doins "${FILESDIR}"/vtund-start.conf
+ rm -r "${ED}"/var || die
+}