summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-05-30 15:19:48 -0400
committerRick Farina <zerochaos@gentoo.org>2019-05-30 15:20:02 -0400
commit0fbc8420dd8b7998bb6a66fc52f287737e838a71 (patch)
tree68512ead6d57023e0a0646d0998d67d6e10bf57c /net-wireless/kismetdb/kismetdb-2019.05.05.ebuild
parentdev-ada/libadalang: enable build with gnat-gpl-2019 (diff)
downloadgentoo-0fbc8420dd8b7998bb6a66fc52f287737e838a71.tar.gz
gentoo-0fbc8420dd8b7998bb6a66fc52f287737e838a71.tar.bz2
gentoo-0fbc8420dd8b7998bb6a66fc52f287737e838a71.zip
net-wireless/kismetdb: bump
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/kismetdb/kismetdb-2019.05.05.ebuild')
-rw-r--r--net-wireless/kismetdb/kismetdb-2019.05.05.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-wireless/kismetdb/kismetdb-2019.05.05.ebuild b/net-wireless/kismetdb/kismetdb-2019.05.05.ebuild
new file mode 100644
index 000000000000..a0a5fee7f90e
--- /dev/null
+++ b/net-wireless/kismetdb/kismetdb-2019.05.05.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Kismetdb database log helper library"
+HOMEPAGE="https://kismetwireless.net/"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://www.kismetwireless.net/git/python-kismet-db.git"
+else
+ SRC_URI="https://github.com/kismetwireless/python-kismet-db/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/python-kismet-db-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/simplekml[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND=""