summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-12-03 22:00:34 -0500
committerRick Farina <zerochaos@gentoo.org>2020-12-03 22:14:07 -0500
commit76fe64f580c4e2d89b3a6952fdf84c0dadbf09cf (patch)
treeb1b9a8e764c34560ee2a440a49caa1701a99e8c7 /net-wireless/soapysdr
parentnet-wireless/nanovna-saver: bump (diff)
downloadgentoo-76fe64f580c4e2d89b3a6952fdf84c0dadbf09cf.tar.gz
gentoo-76fe64f580c4e2d89b3a6952fdf84c0dadbf09cf.tar.bz2
gentoo-76fe64f580c4e2d89b3a6952fdf84c0dadbf09cf.zip
net-wireless/soapysdr: fix qa warnings
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/soapysdr')
-rw-r--r--net-wireless/soapysdr/Manifest2
-rw-r--r--net-wireless/soapysdr/soapysdr-0.7.2.ebuild (renamed from net-wireless/soapysdr/soapysdr-0.7.1.ebuild)12
-rw-r--r--net-wireless/soapysdr/soapysdr-9999.ebuild12
3 files changed, 17 insertions, 9 deletions
diff --git a/net-wireless/soapysdr/Manifest b/net-wireless/soapysdr/Manifest
index 3f6515b2a520..8736fc69bae5 100644
--- a/net-wireless/soapysdr/Manifest
+++ b/net-wireless/soapysdr/Manifest
@@ -1 +1 @@
-DIST soapysdr-0.7.1.tar.gz 124532 BLAKE2B 157c24610b5f89b549a7d670e26ba68cabb923b7fd95bab4adc4896f7fb9e13f58e53671a4802804bc15b09eb1113baddb5879fd14efe8b8ea1bfbff363dde0f SHA512 9b2c4251d6362faecf770df021b74e3b387b99699ae4f7d3f145801e2acc901a3803f7b4d2cd50267013f1add6658703dfa5db6db28b8a645f1f8230117123cd
+DIST soapysdr-0.7.2.tar.gz 124607 BLAKE2B 534480574e2085bddea52141f26e0da8c70157e2c89a0af1236f3d1eb5b996d4ae5231cd209c610fc22d099bd9db665c4c7aea54081eeca2bb293b9eb1fe7c8e SHA512 2454b9b6bf4542f3bce2c6a8e1c886cee9179ca0e13e3c1e22817a05ef671428a3cb8fea69e496c8b62573f360c248508edf3d0871ec5063dfac8211b122d371
diff --git a/net-wireless/soapysdr/soapysdr-0.7.1.ebuild b/net-wireless/soapysdr/soapysdr-0.7.2.ebuild
index f3b498a69d52..d5a5aa7bad6c 100644
--- a/net-wireless/soapysdr/soapysdr-0.7.1.ebuild
+++ b/net-wireless/soapysdr/soapysdr-0.7.2.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit cmake-utils python-r1
+inherit cmake python-r1
DESCRIPTION="vendor and platform neutral SDR support library"
HOMEPAGE="https://github.com/pothosware/SoapySDR"
@@ -13,7 +13,6 @@ HOMEPAGE="https://github.com/pothosware/SoapySDR"
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/pothosware/SoapySDR.git"
EGIT_CLONE_TYPE="shallow"
- KEYWORDS=""
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
@@ -49,5 +48,10 @@ src_configure() {
python_foreach_impl configuration
fi
- cmake-utils_src_configure
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_foreach_impl python_optimize
}
diff --git a/net-wireless/soapysdr/soapysdr-9999.ebuild b/net-wireless/soapysdr/soapysdr-9999.ebuild
index f3b498a69d52..d5a5aa7bad6c 100644
--- a/net-wireless/soapysdr/soapysdr-9999.ebuild
+++ b/net-wireless/soapysdr/soapysdr-9999.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit cmake-utils python-r1
+inherit cmake python-r1
DESCRIPTION="vendor and platform neutral SDR support library"
HOMEPAGE="https://github.com/pothosware/SoapySDR"
@@ -13,7 +13,6 @@ HOMEPAGE="https://github.com/pothosware/SoapySDR"
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/pothosware/SoapySDR.git"
EGIT_CLONE_TYPE="shallow"
- KEYWORDS=""
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
@@ -49,5 +48,10 @@ src_configure() {
python_foreach_impl configuration
fi
- cmake-utils_src_configure
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_foreach_impl python_optimize
}