summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-15 12:25:35 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-15 12:25:35 +0200
commit03158c436958b062a04343bf333c4fe68a06837a (patch)
tree0baddb993e0c5d965358d284660dcb5e3d80ed58 /sci-astronomy/celestia
parentsci-astronomy/celestia: More fixes for the live ebuild. (diff)
downloadgentoo-03158c436958b062a04343bf333c4fe68a06837a.tar.gz
gentoo-03158c436958b062a04343bf333c4fe68a06837a.tar.bz2
gentoo-03158c436958b062a04343bf333c4fe68a06837a.zip
sci-astronomy/celestia: Removed gnome support in live ebuild.
Bug: https://bugs.gentoo.org/644334 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'sci-astronomy/celestia')
-rw-r--r--sci-astronomy/celestia/celestia-9999.ebuild45
1 files changed, 12 insertions, 33 deletions
diff --git a/sci-astronomy/celestia/celestia-9999.ebuild b/sci-astronomy/celestia/celestia-9999.ebuild
index b8b02e1fa2fe..23ad6bc99f7c 100644
--- a/sci-astronomy/celestia/celestia-9999.ebuild
+++ b/sci-astronomy/celestia/celestia-9999.ebuild
@@ -3,15 +3,13 @@
EAPI=6
-inherit autotools flag-o-matic gnome2 xdg-utils
+inherit autotools flag-o-matic xdg-utils
DESCRIPTION="OpenGL 3D space simulator"
HOMEPAGE="https://celestia.space"
if [[ "${PV}" = 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/CelestiaProject/Celestia.git"
- # Necessary because of gnome2 eclass
- SRC_URI=""
else
# Old URI! Please update once we have a release > v1.6.1
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -20,7 +18,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="cairo gnome gtk nls pch theora threads"
+IUSE="cairo gtk nls pch theora threads"
RDEPEND="
virtual/opengl
@@ -31,18 +29,13 @@ RDEPEND="
x11-libs/gtk+:2
>=x11-libs/gtkglext-1.0
)
- gnome? (
- >=gnome-base/libgnomeui-2.0
- )
- !gtk? ( !gnome? ( media-libs/freeglut ) )
+ !gtk? ( media-libs/freeglut )
cairo? ( x11-libs/cairo )
theora? ( media-libs/libtheora )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-REQUIRED_USE="gnome? ( gtk )"
-
PATCHES=(
# make better desktop files
"${FILESDIR}"/${PN}-1.5.0-desktop.patch
@@ -56,15 +49,11 @@ PATCHES=(
pkg_setup() {
# Check for one for the following use flags to be set.
- if use gnome; then
- einfo "USE=\"gnome\" detected."
- USE_DESTDIR="1"
- CELESTIA_GUI="gnome"
- elif use gtk; then
+ if use gtk; then
einfo "USE=\"gtk\" detected."
CELESTIA_GUI="gtk"
else
- ewarn "If you want to use the full gui, set USE=\"{gnome|gtk}\""
+ ewarn "If you want to use the full gui, set USE=\"gtk\""
ewarn "Defaulting to glut support (no GUI)."
CELESTIA_GUI="glut"
fi
@@ -74,7 +63,7 @@ src_prepare() {
default
# remove flags to let the user decide
- local
+ local cf
for cf in -O2 -ffast-math \
-fexpensive-optimizations \
-fomit-frame-pointer; do
@@ -82,13 +71,6 @@ src_prepare() {
-e "s/${cf}//g" \
configure.ac admin/* || die "sed failed"
done
- # remove an unused gconf macro killing autoconf when no gnome
- # (not needed without eautoreconf)
- if ! use gnome; then
- sed -i \
- -e '/AM_GCONF_SOURCE_2/d' \
- configure.ac || die "sed failed"
- fi
eautoreconf
filter-flags "-funroll-loops -frerun-loop-opt"
@@ -114,15 +96,12 @@ src_configure() {
}
src_install() {
- if [[ ${CELESTIA_GUI} == gnome ]]; then
- gnome2_src_install
- else
- emake DESTDIR="${D}" MKDIR_P="mkdir -p" install
- local size
- for size in 16 22 32 48 ; do
- newicon "${S}"/src/celestia/kde/data/hi${size}-app-${PN}.png ${PN}.png
- done
- fi
+ emake DESTDIR="${D}" install
+ local size
+ for size in 16 22 32 48 ; do
+ newicon "${S}"/src/celestia/kde/data/hi${size}-app-${PN}.png ${PN}.png
+ done
+
[[ ${CELESTIA_GUI} == glut ]] && domenu celestia.desktop
dodoc AUTHORS README TRANSLATORS *.txt
}