summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/bamtools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/bamtools')
-rw-r--r--sci-biology/bamtools/Manifest2
-rw-r--r--sci-biology/bamtools/bamtools-1.0.2.ebuild33
-rw-r--r--sci-biology/bamtools/bamtools-2.3.0.ebuild28
-rw-r--r--sci-biology/bamtools/files/bamtools-2.2.3-unbundle.patch32
-rw-r--r--sci-biology/bamtools/files/bamtools-2.3.0-unbundle.patch23
-rw-r--r--sci-biology/bamtools/metadata.xml14
6 files changed, 132 insertions, 0 deletions
diff --git a/sci-biology/bamtools/Manifest b/sci-biology/bamtools/Manifest
new file mode 100644
index 000000000000..1c1972c599d5
--- /dev/null
+++ b/sci-biology/bamtools/Manifest
@@ -0,0 +1,2 @@
+DIST bamtools-1.0.2.tar.gz 207523 SHA256 d3ca75d2bec531f15dbc400a76afbe48d47452ce05552c88943bbce81a0862d8 SHA512 1934d40d50f3fdf2b1fcacb8b59cf954a3c791d3095649ac4f1246563e9d8d4afe385e42a2c6c383f0bb519eede401d12c71203d279b33e01575222f9f84c244 WHIRLPOOL 9fb4d4feb3ff867866a96533231a1b8284fd5156ab142cad727d32f8f3c157e246cca59185c3bdc253b19bde2514404a7107a62443780b060f6e8f270622c990
+DIST bamtools-2.3.0.tar.gz 539446 SHA256 288046e6d5d41afdc5fce8608c5641cf2b8e670644587c1315b90bbe92f039af SHA512 432f66384cffc04ab6bc7dc66d8f7b79c1e468d0068db4cabb5cac05f9b6bef7968eff71ffb3ee51b84e23d9bb66a11ef267024138f40116c25e7f18e7210a5c WHIRLPOOL dd888f67c3d0b0ce2f5f2875e242e5df0d54cefd13693230b5f10eb57dd780304b601027cf65f6598a54061a7166903bf06c6c9a46939f6ce6bbb246cab89993
diff --git a/sci-biology/bamtools/bamtools-1.0.2.ebuild b/sci-biology/bamtools/bamtools-1.0.2.ebuild
new file mode 100644
index 000000000000..08c40d0705d3
--- /dev/null
+++ b/sci-biology/bamtools/bamtools-1.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="A programmer's API and an end-user's toolkit for handling BAM files"
+HOMEPAGE="https://github.com/pezmaster31/bamtools"
+SRC_URI="mirror://github/pezmaster31/bamtools/"${P}".tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ for i in bin/bamtools-${PV} lib/libbamtools.so.${PV} lib/libbamtools-utils.so.${PV}; do
+ TMPDIR="$(pwd)" scanelf -Xr $i || die
+ done
+
+ dobin bin/bamtools
+ dolib lib/*
+ insinto /usr/include/bamtools/api
+ doins include/api/*
+ insinto /usr/include/bamtools/shared
+ doins include/shared/*
+ dodoc README
+}
diff --git a/sci-biology/bamtools/bamtools-2.3.0.ebuild b/sci-biology/bamtools/bamtools-2.3.0.ebuild
new file mode 100644
index 000000000000..cb86750cc0cf
--- /dev/null
+++ b/sci-biology/bamtools/bamtools-2.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A programmer's API and an end-user's toolkit for handling BAM files"
+HOMEPAGE="https://github.com/pezmaster31/bamtools"
+SRC_URI="https://github.com/pezmaster31/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ >=dev-libs/jsoncpp-0.5.0-r1
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-unbundle.patch )
+
+src_install() {
+ cmake-utils_src_install
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a
+}
diff --git a/sci-biology/bamtools/files/bamtools-2.2.3-unbundle.patch b/sci-biology/bamtools/files/bamtools-2.2.3-unbundle.patch
new file mode 100644
index 000000000000..318396e75c36
--- /dev/null
+++ b/sci-biology/bamtools/files/bamtools-2.2.3-unbundle.patch
@@ -0,0 +1,32 @@
+ src/CMakeLists.txt | 1 -
+ src/api/CMakeLists.txt | 4 ++--
+ src/toolkit/bamtools_filter.cpp | 2 +-
+ 3 files changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index e359695..2bd2185 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -6,7 +6,6 @@
+ # ==========================
+
+ add_subdirectory( api )
+-add_subdirectory( third_party )
+ add_subdirectory( toolkit )
+ add_subdirectory( utils )
+
+diff --git a/src/api/CMakeLists.txt b/src/api/CMakeLists.txt
+index 66eb35f..65f4639 100644
+--- a/src/api/CMakeLists.txt
++++ b/src/api/CMakeLists.txt
+@@ -54,8 +54,8 @@ target_link_libraries( BamTools ${APILibs} )
+ target_link_libraries( BamTools-static ${APILibs} )
+
+ # set library install destinations
+-install( TARGETS BamTools LIBRARY DESTINATION "lib/bamtools" RUNTIME DESTINATION "bin")
+-install( TARGETS BamTools-static ARCHIVE DESTINATION "lib/bamtools")
++install( TARGETS BamTools LIBRARY DESTINATION "lib${LIB_SUFFIX}" RUNTIME DESTINATION "bin")
++install( TARGETS BamTools-static ARCHIVE DESTINATION "lib${LIB_SUFFIX}")
+
+ # export API headers
+ include(../ExportHeader.cmake)
diff --git a/sci-biology/bamtools/files/bamtools-2.3.0-unbundle.patch b/sci-biology/bamtools/files/bamtools-2.3.0-unbundle.patch
new file mode 100644
index 000000000000..c07c59d2cddd
--- /dev/null
+++ b/sci-biology/bamtools/files/bamtools-2.3.0-unbundle.patch
@@ -0,0 +1,23 @@
+--- bamtools-2.3.0/src/api/CMakeLists.txt.ori 2013-08-27 18:00:43.000000000 +0200
++++ bamtools-2.3.0/src/api/CMakeLists.txt 2013-08-27 18:00:47.000000000 +0200
+@@ -54,8 +54,8 @@
+ target_link_libraries( BamTools-static ${APILibs} )
+
+ # set library install destinations
+-install( TARGETS BamTools LIBRARY DESTINATION "lib/bamtools" RUNTIME DESTINATION "bin")
+-install( TARGETS BamTools-static ARCHIVE DESTINATION "lib/bamtools")
++install( TARGETS BamTools LIBRARY DESTINATION "lib${LIB_SUFFIX}" RUNTIME DESTINATION "bin")
++install( TARGETS BamTools-static ARCHIVE DESTINATION "lib${LIB_SUFFIX}")
+
+ # export API headers
+ include(../ExportHeader.cmake)
+--- bamtools-2.3.0/src/CMakeLists.txt.ori 2013-08-27 18:03:10.000000000 +0200
++++ bamtools-2.3.0/src/CMakeLists.txt 2013-08-27 18:03:23.000000000 +0200
+@@ -6,7 +6,6 @@
+ # ==========================
+
+ add_subdirectory( api )
+-add_subdirectory( third_party )
+ add_subdirectory( toolkit )
+ add_subdirectory( utils )
+
diff --git a/sci-biology/bamtools/metadata.xml b/sci-biology/bamtools/metadata.xml
new file mode 100644
index 000000000000..f2c00c1fdd0c
--- /dev/null
+++ b/sci-biology/bamtools/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>mmokrejs@gmail.com</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <longdescription>BAM (Binary Alignment/Map) format is useful for storing large DNA sequence alignments. It is closely related to the text-based SAM format, but optimized for random-access. BamTools provides a fast, flexible C++ API for reading and writing BAM files.</longdescription>
+ <upstream>
+ <remote-id type="github">pezmaster31/bamtools</remote-id>
+ </upstream>
+</pkgmetadata>