summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/pysam
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/pysam')
-rw-r--r--sci-biology/pysam/Manifest1
-rw-r--r--sci-biology/pysam/metadata.xml8
-rw-r--r--sci-biology/pysam/pysam-0.6-r1.ebuild25
3 files changed, 34 insertions, 0 deletions
diff --git a/sci-biology/pysam/Manifest b/sci-biology/pysam/Manifest
new file mode 100644
index 000000000000..4aea08f2d664
--- /dev/null
+++ b/sci-biology/pysam/Manifest
@@ -0,0 +1 @@
+DIST pysam-0.6.tar.gz 841790 SHA256 081c980481f31a81acb06f6fa5638b899321eddfd9eeb5075393e4dad84a1fc8 SHA512 b60df4551600f04e8ae67aec0f2745846d2411e2a1cc4c874ef296ee80ab075256190ebb0ec64eb78231d4d7b59670c5259818cd315f52c923774cc4c0b8b391 WHIRLPOOL eddeb19f3ebf0c6326f7c1b6b7224b2b8cb708e0bf7ceb66b1cac18909abafd1704b264452b70ee6721af4b3b360b51285dcffd7f137c6128920f91dc0dec7b2
diff --git a/sci-biology/pysam/metadata.xml b/sci-biology/pysam/metadata.xml
new file mode 100644
index 000000000000..49afc3c3d532
--- /dev/null
+++ b/sci-biology/pysam/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <upstream>
+ <remote-id type="google-code">pysam</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-biology/pysam/pysam-0.6-r1.ebuild b/sci-biology/pysam/pysam-0.6-r1.ebuild
new file mode 100644
index 000000000000..3873100fa45f
--- /dev/null
+++ b/sci-biology/pysam/pysam-0.6-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for the SAM/BAM sequence alignment and mapping format"
+HOMEPAGE="http://code.google.com/p/pysam http://pypi.python.org/pypi/pysam"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}