summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-06-03 09:39:24 +0100
committerJustin Lecher <jlec@gentoo.org>2017-06-03 09:39:46 +0100
commit6ab0c4e462358187dbd1071f2025dc2a7b97fb33 (patch)
tree2d2866dfe897273beb161c703e782c2dbe3cae2c /sci-chemistry/molsketch/files
parentsci-chemistry/openbabel: Fix API doc installation (diff)
downloadgentoo-6ab0c4e462358187dbd1071f2025dc2a7b97fb33.tar.gz
gentoo-6ab0c4e462358187dbd1071f2025dc2a7b97fb33.tar.bz2
gentoo-6ab0c4e462358187dbd1071f2025dc2a7b97fb33.zip
sci-chemistry/molsketch: Version Bump
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=605870 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry/molsketch/files')
-rw-r--r--sci-chemistry/molsketch/files/molsketch-0.2.0-openbabel-231.patch54
-rw-r--r--sci-chemistry/molsketch/files/molsketch-0.4.1-more-quotes.patch11
-rw-r--r--sci-chemistry/molsketch/files/molsketch-0.4.1-no-quotes.patch16
3 files changed, 27 insertions, 54 deletions
diff --git a/sci-chemistry/molsketch/files/molsketch-0.2.0-openbabel-231.patch b/sci-chemistry/molsketch/files/molsketch-0.2.0-openbabel-231.patch
deleted file mode 100644
index 41ddf01df5f8..000000000000
--- a/sci-chemistry/molsketch/files/molsketch-0.2.0-openbabel-231.patch
+++ /dev/null
@@ -1,54 +0,0 @@
- CMakeLists.txt | 12 ++++++------
- libmolsketch/src/stereocenteritem.cpp | 2 +-
- 2 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a4b5d29..f472b40 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -12,10 +12,10 @@ set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules)
- # compiler issues are fixed and more warnings are issued. #
- ###########################################################
- if (CMAKE_COMPILER_IS_GNUCXX)
-- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align")
-- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror-implicit-function-declaration -Wchar-subscripts")
-- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security")
-- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wmissing-format-attribute -fno-common")
-+# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align")
-+# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror-implicit-function-declaration -Wchar-subscripts")
-+# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security")
-+# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wmissing-format-attribute -fno-common")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-exceptions -fno-check-new -fno-common")
-@@ -32,7 +32,7 @@ set(CPACK_SOURCE_IGNORE_FILES "/build;/.git")
- include(CPack)
-
- # Unit testing, mainly useful for developers and so defaults to off
--option(ENABLE_TESTS "Enable unit testing" ON)
-+option(ENABLE_TESTS "Enable unit testing" OFF)
- if(ENABLE_TESTS)
- set(QT_USE_QTTEST TRUE)
- enable_testing()
-@@ -48,7 +48,7 @@ configure_file("${CMAKE_MODULE_PATH}/cmake_uninstall.cmake.in"
- add_custom_target(uninstall "${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")
-
- # Enabling debugging symbols
--set(CMAKE_BUILD_TYPE Debug)
-+# set(CMAKE_BUILD_TYPE Debug)
-
- # Enabling shared libraries
- set(BUILD_SHARED_LIBS OFF)
-diff --git a/libmolsketch/src/stereocenteritem.cpp b/libmolsketch/src/stereocenteritem.cpp
-index 44a8015..20f2a4a 100644
---- a/libmolsketch/src/stereocenteritem.cpp
-+++ b/libmolsketch/src/stereocenteritem.cpp
-@@ -63,7 +63,7 @@ namespace Molsketch {
- graphsym.GetSymmetry(symmetry_classes);
-
- //std::vector<unsigned long> atomIds = FindTetrahedralAtoms(obmol, symmetry_classes);
-- std::vector<OpenBabel::StereogenicUnit> units = FindStereogenicUnits(obmol, symmetry_classes);
-+ OpenBabel::OBStereoUnitSet units = FindStereogenicUnits(obmol, symmetry_classes);
-
- for (unsigned int i = 0; i < units.size(); ++i) {
- if (units.at(i).type == OpenBabel::OBStereo::Tetrahedral) {
diff --git a/sci-chemistry/molsketch/files/molsketch-0.4.1-more-quotes.patch b/sci-chemistry/molsketch/files/molsketch-0.4.1-more-quotes.patch
new file mode 100644
index 000000000000..c32b975778eb
--- /dev/null
+++ b/sci-chemistry/molsketch/files/molsketch-0.4.1-more-quotes.patch
@@ -0,0 +1,11 @@
+--- a/libmolsketch/src/molscene.cpp
++++ b/libmolsketch/src/molscene.cpp
+@@ -842,7 +842,7 @@
+ void MolScene::dragEnterEvent(QGraphicsSceneDragDropEvent *event)
+ {
+ if (!event->mimeData() || !event->mimeData()->hasFormat(mimeType())) return;
+- if (!event->proposedAction() == Qt::CopyAction) return;
++ if ((!event->proposedAction()) == Qt::CopyAction) return;
+ event->accept();
+ for (genericAction* action : sceneActions())
+ action->setChecked(false);
diff --git a/sci-chemistry/molsketch/files/molsketch-0.4.1-no-quotes.patch b/sci-chemistry/molsketch/files/molsketch-0.4.1-no-quotes.patch
new file mode 100644
index 000000000000..1b63ed51edec
--- /dev/null
+++ b/sci-chemistry/molsketch/files/molsketch-0.4.1-no-quotes.patch
@@ -0,0 +1,16 @@
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 64c18a2..75c2fb7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -97,7 +97,7 @@ endif(Qt5Core_FOUND AND Qt5Widgets_FOUND AND Qt5Gui_FOUND AND Qt5PrintSupport_FO
+ if(FORCEQt4)
+ add_definitions(-DQTVERSIONSUFFIX="")
+ else(FORCEQt4)
+- add_definitions(-DQTVERSIONSUFFIX="\\\"-qt5\\\"")
++ add_definitions(-DQTVERSIONSUFFIX="-qt5")
+ endif(FORCEQt4)
+
+ ################ Reading version and default paths