summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2015-09-07 17:08:14 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2015-09-07 17:11:24 +0200
commita51da4f7acfb2da41cb5729c00d19c96cbed63c2 (patch)
treed6aab61b0f9b9e5f7654b1349243325684d7dbd4 /sci-electronics/gsmc/gsmc-1.1-r2.ebuild
parentsys-libs/libomp: initial import (diff)
downloadgentoo-a51da4f7acfb2da41cb5729c00d19c96cbed63c2.tar.gz
gentoo-a51da4f7acfb2da41cb5729c00d19c96cbed63c2.tar.bz2
gentoo-a51da4f7acfb2da41cb5729c00d19c96cbed63c2.zip
sci-electronics/gsmc: Add missing libm (bug 503774). Thanks B. Leverett. Bump to EAPI=5
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-electronics/gsmc/gsmc-1.1-r2.ebuild')
-rw-r--r--sci-electronics/gsmc/gsmc-1.1-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-electronics/gsmc/gsmc-1.1-r2.ebuild b/sci-electronics/gsmc/gsmc-1.1-r2.ebuild
new file mode 100644
index 000000000000..01fe3a6b0b8b
--- /dev/null
+++ b/sci-electronics/gsmc/gsmc-1.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="A GTK program for doing Smith Chart calculations"
+HOMEPAGE="http://www.qsl.net/ik5nax/"
+SRC_URI="http://www.qsl.net/ik5nax/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-autotools.patch"
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS NEWS README TODO
+ insinto /usr/share/${PN}
+ doins example*
+}