summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/gerris/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/gerris/files')
-rw-r--r--sci-libs/gerris/files/gerris-20130531-hypre-no-mpi.patch22
-rw-r--r--sci-libs/gerris/files/gerris-20130531-lis-matrix-csr.patch11
-rw-r--r--sci-libs/gerris/files/gerris-20130531-use-blas-lapack-system.patch33
-rw-r--r--sci-libs/gerris/files/gerris-hypre-no-mpi.patch21
4 files changed, 87 insertions, 0 deletions
diff --git a/sci-libs/gerris/files/gerris-20130531-hypre-no-mpi.patch b/sci-libs/gerris/files/gerris-20130531-hypre-no-mpi.patch
new file mode 100644
index 000000000000..f05512efbddf
--- /dev/null
+++ b/sci-libs/gerris/files/gerris-20130531-hypre-no-mpi.patch
@@ -0,0 +1,22 @@
+patch to allow gerris to use hypre without mpi
+
+--- configure.ac 2013-05-30 23:57:18.000000000 -0700
++++ configure.ac.new 2013-07-22 13:52:36.083974663 -0700
+@@ -336,7 +336,7 @@
+
+ # Build hypre module if HYPRE is installed
+ hypre=no
+-if test "x$use_mpicc" = "xyes" ; then # HYPRE needs MPI
++# hypre does not need mpi
+ AC_CHECK_LIB(HYPRE, HYPRE_IJMatrixCreate, hypre="yes", hypre="no", [-lm])
+ if test x$hypre = xyes; then
+ AC_CHECK_HEADERS(HYPRE.h, hypre="yes", hypre="no")
+@@ -344,7 +344,7 @@
+ if test x$hypre = xno; then
+ AC_MSG_WARN([HYPRE not found. hypre Module won't be available.])
+ fi
+-fi
++
+ AM_CONDITIONAL(BUILD_HYPRE, test x$hypre = xyes)
+
+ # Build lis module if lis is installed
diff --git a/sci-libs/gerris/files/gerris-20130531-lis-matrix-csr.patch b/sci-libs/gerris/files/gerris-20130531-lis-matrix-csr.patch
new file mode 100644
index 000000000000..21d6810bbd2b
--- /dev/null
+++ b/sci-libs/gerris/files/gerris-20130531-lis-matrix-csr.patch
@@ -0,0 +1,11 @@
+--- modules/lis.c.orig 2013-07-22 15:34:05.346631560 -0700
++++ modules/lis.c 2013-07-22 15:33:28.621427315 -0700
+@@ -45,7 +45,7 @@
+ g_array_index (stencil->coeff, double, j),
+ A);
+ }
+- lis_matrix_set_type (A, LIS_MATRIX_CRS);
++ lis_matrix_set_type (A, LIS_MATRIX_CSR);
+ lis_matrix_assemble (A);
+
+ LIS_VECTOR b, x;
diff --git a/sci-libs/gerris/files/gerris-20130531-use-blas-lapack-system.patch b/sci-libs/gerris/files/gerris-20130531-use-blas-lapack-system.patch
new file mode 100644
index 000000000000..4c8985ce5e77
--- /dev/null
+++ b/sci-libs/gerris/files/gerris-20130531-use-blas-lapack-system.patch
@@ -0,0 +1,33 @@
+--- modules/Makefile.am.orig 2013-07-22 14:13:10.339130133 -0700
++++ modules/Makefile.am 2013-07-22 14:15:10.770813929 -0700
+@@ -105,7 +105,7 @@
+ libstokes2D_la_LIBADD = $(GFS2D_LIBS)
+
+ libwavewatch2D_la_SOURCES = wavewatch.c
+-libwavewatch2D_la_LIBADD = $(GFS2D_LIBS) -Lwavewatch -lwavewatch -L/usr/lib/gcc/i486-linux-gnu/4.2 -lgfortran
++libwavewatch2D_la_LIBADD = $(GFS2D_LIBS) -Lwavewatch -lwavewatch
+ libwavewatch2D_la_CFLAGS = $(AM_CFLAGS) -DFTT_2D=1 \
+ -DW3SRCE=`nm wavewatch/libwavewatch.a | grep w3srce | awk '{ if ($$2 == "T") print $$3; }'` \
+ -DGFSW3INIT=`nm wavewatch/libwavewatch.a | grep gfsw3_init | awk '{ if ($$2 == "T") print $$3; }'`
+@@ -164,17 +164,17 @@
+
+ liblis3D_la_SOURCES = lis.c
+ liblis3D_la_CFLAGS = $(AM_CFLAGS)
+-liblis3D_la_LIBADD = $(GFS3D_LIBS) -llis -lgfortran -lm
++liblis3D_la_LIBADD = $(GFS3D_LIBS) -llis -lm
+ liblis2D_la_SOURCES = lis.c
+ liblis2D_la_CFLAGS = $(AM_CFLAGS) -DFTT_2D=1
+-liblis2D_la_LIBADD = $(GFS2D_LIBS) -llis -lgfortran -lm
++liblis2D_la_LIBADD = $(GFS2D_LIBS) -llis -lm
+
+ libagmg3D_la_SOURCES = agmg.c dagmg.f90
+ libagmg3D_la_CFLAGS = $(AM_CFLAGS)
+-libagmg3D_la_LIBADD = $(GFS3D_LIBS) -llapack -lblas -lgfortran -lm
++libagmg3D_la_LIBADD = $(GFS3D_LIBS) $(LAPACK_LIBS) $(BLAS_LIBS) -lm
+ libagmg2D_la_SOURCES = agmg.c dagmg.f90
+ libagmg2D_la_CFLAGS = $(AM_CFLAGS) -DFTT_2D=1
+-libagmg2D_la_LIBADD = $(GFS2D_LIBS) -llapack -lblas -lgfortran -lm
++libagmg2D_la_LIBADD = $(GFS2D_LIBS) $(LAPACK_LIBS) $(BLAS_LIBS) -lm
+
+ libokada3D_la_SOURCES = okada.c
+ libokada3D_la_CFLAGS = $(AM_CFLAGS)
diff --git a/sci-libs/gerris/files/gerris-hypre-no-mpi.patch b/sci-libs/gerris/files/gerris-hypre-no-mpi.patch
new file mode 100644
index 000000000000..2e3aede8b7d6
--- /dev/null
+++ b/sci-libs/gerris/files/gerris-hypre-no-mpi.patch
@@ -0,0 +1,21 @@
+--- configure.in.orig 2012-08-08 17:19:49.374366942 +0100
++++ configure.in 2012-08-08 17:20:40.585155226 +0100
+@@ -334,7 +334,8 @@
+
+ # Build hypre module if HYPRE is installed
+ hypre=no
+-if test "x$use_mpicc" = "xyes" ; then # HYPRE needs MPI
++# hypre does not need mpi
++#if test "x$use_mpicc" = "xyes" ; then # HYPRE needs MPI
+ AC_CHECK_LIB(HYPRE, HYPRE_IJMatrixCreate, hypre="yes", hypre="no", [-lm])
+ if test x$hypre = xyes; then
+ AC_CHECK_HEADERS(HYPRE.h, hypre="yes", hypre="no")
+@@ -342,7 +343,7 @@
+ if test x$hypre = xno; then
+ AC_MSG_WARN([HYPRE not found. hypre Module won't be available.])
+ fi
+-fi
++#fi
+ AM_CONDITIONAL(BUILD_HYPRE, test x$hypre = xyes)
+
+ # Build lis module if lis is installed