summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-12 01:31:21 +0100
committerSam James <sam@gentoo.org>2021-04-12 02:07:35 +0100
commit04a4df8b2b01985d63ee09cfc64bf832ab210fcb (patch)
tree233a8a81000e91f380c6d441a4ee7e3ae43cb21f /sci-libs/numkit/numkit-1.1.2-r1.ebuild
parentsci-chemistry/GromacsWrapper: fix RDEPEND typo (diff)
downloadgentoo-04a4df8b2b01985d63ee09cfc64bf832ab210fcb.tar.gz
gentoo-04a4df8b2b01985d63ee09cfc64bf832ab210fcb.tar.bz2
gentoo-04a4df8b2b01985d63ee09cfc64bf832ab210fcb.zip
sci-libs/numkit: fix RDEPEND typo
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/numkit/numkit-1.1.2-r1.ebuild')
-rw-r--r--sci-libs/numkit/numkit-1.1.2-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-libs/numkit/numkit-1.1.2-r1.ebuild b/sci-libs/numkit/numkit-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..80b313603db7
--- /dev/null
+++ b/sci-libs/numkit/numkit-1.1.2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Numerical first aid kit (with numpy/scipy)"
+HOMEPAGE="https://numkit.readthedocs.io"
+S="${WORKDIR}/${PN}-release-${PV}"
+SRC_URI="https://github.com/Becksteinlab/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.9[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.0[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}"