summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2023-07-28 11:16:19 -0400
committerRick Farina <zerochaos@gentoo.org>2023-07-28 14:23:26 -0400
commit39c16fbdb169edd3f0f525960af9ba8cf3af315a (patch)
tree6761b7790305cb25a1600e39679110ee7b2ad96d /sci-libs/volk
parentnet-wireless/gnuradio: add 3.10.7.0 (diff)
downloadgentoo-39c16fbdb169edd3f0f525960af9ba8cf3af315a.tar.gz
gentoo-39c16fbdb169edd3f0f525960af9ba8cf3af315a.tar.bz2
gentoo-39c16fbdb169edd3f0f525960af9ba8cf3af315a.zip
sci-libs/volk: add 3.0.0
Signed-off-by: Rick Farina <zerochaos@gentoo.org> Closes: https://bugs.gentoo.org/878737
Diffstat (limited to 'sci-libs/volk')
-rw-r--r--sci-libs/volk/Manifest1
-rw-r--r--sci-libs/volk/volk-3.0.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-libs/volk/Manifest b/sci-libs/volk/Manifest
index 6fc90e0540df..894376e9d01a 100644
--- a/sci-libs/volk/Manifest
+++ b/sci-libs/volk/Manifest
@@ -1 +1,2 @@
DIST volk-2.5.1.tar.xz 362792 BLAKE2B dfaaddb9e6910c2e7d9d493c87922cf95ae3c70fff5644c7295f02e474d5fabdc2c9f42dbcc2d9d85cc25e9b6c3ba9ec8671b580093a35af1402183fa18df93a SHA512 4946b1675293920dc6e716b0a7927ce845abd833b2a33c41542b90760c6ab6832a1faede4c783133b32e616d69a8fcf2d131ca54cd504b0596fc0a92030cd1fa
+DIST volk-3.0.0.tar.xz 394044 BLAKE2B 04e832916375610571387db521348df2a37f5460500c4bd6d223dd6af9c0a207f3b22c599fccbf9bd51b8a87ed90cb5239512c19fc6ddd02320b7aa27c3be588 SHA512 5d1ff90f28ec6ef2d21370d74025139ccc9872e5a477b271ffe6662725b7705203715ea4ffc430554ec2fec56e8d9b40a945e75186761995d3075218e1f16313
diff --git a/sci-libs/volk/volk-3.0.0.ebuild b/sci-libs/volk/volk-3.0.0.ebuild
new file mode 100644
index 000000000000..966205b0e596
--- /dev/null
+++ b/sci-libs/volk/volk-3.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+#https://github.com/gnuradio/volk/issues/383
+CMAKE_BUILD_TYPE="None"
+inherit cmake python-single-r1
+
+DESCRIPTION="vector optimized library of kernels"
+HOMEPAGE="http://libvolk.org"
+SRC_URI="https://github.com/gnuradio/volk/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+IUSE="orc test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="${PYTHON_DEPS}
+ net-wireless/gnuradio
+ dev-libs/boost:=
+ orc? ( dev-lang/orc )"
+DEPEND="${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mako[${PYTHON_USEDEP}]')"
+
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ORC=$(usex orc)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DENABLE_TESTING="$(usex test)"
+ -DENABLE_PROFILING=OFF
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ # Remove stray python files generated by the build system
+ find "${ED}" -name '*.pyc' -exec rm -f {} \; || die
+ find "${ED}" -name '*.pyo' -exec rm -f {} \; || die
+ python_optimize
+}