summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexei Colin <ac@alexeicolin.com>2021-02-16 10:12:06 -0500
committerMichael Orlitzky <mjo@gentoo.org>2021-03-25 20:56:24 -0400
commit228d6b6db2105f56271f66434d329edc19afb852 (patch)
tree555ab22a0529096e7cd2eda850353fb59aba60e4 /sci-libs/vtk
parentdev-lua/luasec: Version updated to 1.0. (diff)
downloadgentoo-228d6b6db2105f56271f66434d329edc19afb852.tar.gz
gentoo-228d6b6db2105f56271f66434d329edc19afb852.tar.bz2
gentoo-228d6b6db2105f56271f66434d329edc19afb852.zip
sci-libs/vtk: 8.2.0: update deprecated var for setting Python site-dir
Problem: On some platforms (ppc64le), Python modules are installed into $EPREFIX/usr/lib64/pythonX.Y/site-packages instead of $EPREFIX/usr/lib/pythonX.Y/site-packages Reason: The ebuild sets VTK_INSTALL_PYTHON_MODULE_DIR, but it has been deprecated and thus has no effect. Thus, the install directory used is the default install directory, and for some reason it's /usr/lib64 instead of /usr/lib. The only reference to the deprecated var in v8.2.0 is to print the deprecation warning: ./CMake/vtkDirectories.cmake:29:if(DEFINED VTK_INSTALL_PYTHON_MODULE_DIR) ./CMake/vtkDirectories.cmake-30- message(WARNING ./CMake/vtkDirectories.cmake:31: "VTK_INSTALL_PYTHON_MODULE_DIR is no longer supported. " ./CMake/vtkDirectories.cmake-32- "Set `VTK_PYTHON_SITE_PACKAGES_SUFFIX` instead, although not needed in most cases.") ./CMake/vtkDirectories.cmake-33-endif() Note that in versions >8.2.0, this warning has been removed, too. The fix: VTK_INSTALL_PYTHON_MODULES_DIR is still honored, including in >8.2.0, so use it instead. Note that VTK_PYTHON_SITE_PACKAGES_SUFFIX does not help because it is appended after the lib directory in the path. Perhaps a deeper fix might be to figure out why the default lib dir is set to lib64 instead of lib. I didn't investigate this further. The ebuild already intends to override the default, and this commit just fixes that override. I don't know if the default dir is still broken in >8.2.0, i.e. whether it is still necessary for the >8.2.0 ebuilds to override the default installation directory. There have been related changes, though, see at least this commit that's not in 8.2.0 but is in master: commit 4c42ff417c209087bf0058a9eb2614928943156b Author: Ben Boeckel <ben.boeckel@kitware.com> Date: Thu Oct 18 13:17:11 2018 -0400 vtkPython: expose VTK_PYTHONPATH to consumers of VTK Signed-off-by: Alexei Colin <ac@alexeicolin.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/vtk-8.2.0-r1.ebuild2
-rw-r--r--sci-libs/vtk/vtk-8.2.0.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sci-libs/vtk/vtk-8.2.0-r1.ebuild b/sci-libs/vtk/vtk-8.2.0-r1.ebuild
index 12dba470d8a1..9ab67fa0c1e0 100644
--- a/sci-libs/vtk/vtk-8.2.0-r1.ebuild
+++ b/sci-libs/vtk/vtk-8.2.0-r1.ebuild
@@ -254,7 +254,7 @@ src_configure() {
if use python; then
mycmakeargs+=(
- -DVTK_INSTALL_PYTHON_MODULE_DIR="$(python_get_sitedir)"
+ -DVTK_INSTALL_PYTHON_MODULES_DIR="$(python_get_sitedir)"
-DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
-DPYTHON_LIBRARY="$(python_get_library_path)"
-DSIP_PYQT_DIR="${EPREFIX}/usr/share/sip"
diff --git a/sci-libs/vtk/vtk-8.2.0.ebuild b/sci-libs/vtk/vtk-8.2.0.ebuild
index 0c4458bbb7f3..0eab965aa3f4 100644
--- a/sci-libs/vtk/vtk-8.2.0.ebuild
+++ b/sci-libs/vtk/vtk-8.2.0.ebuild
@@ -248,7 +248,7 @@ src_configure() {
if use python; then
mycmakeargs+=(
- -DVTK_INSTALL_PYTHON_MODULE_DIR="$(python_get_sitedir)"
+ -DVTK_INSTALL_PYTHON_MODULES_DIR="$(python_get_sitedir)"
-DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
-DPYTHON_LIBRARY="$(python_get_library_path)"
-DSIP_PYQT_DIR="${EPREFIX}/usr/share/sip"