summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-01-05 15:34:04 +0000
committerSam James <sam@gentoo.org>2024-03-08 19:22:03 +0000
commit37c050e03ecc2b9f839113d7fbbd31220ba32b4d (patch)
tree2710e062b27bb624a252cb17b8fcfe0221057aec /sci-libs
parentsci-libs/rocFFT: fix benchmark dependencies and collision with dev-util/perf (diff)
downloadgentoo-37c050e03ecc2b9f839113d7fbbd31220ba32b4d.tar.gz
gentoo-37c050e03ecc2b9f839113d7fbbd31220ba32b4d.tar.bz2
gentoo-37c050e03ecc2b9f839113d7fbbd31220ba32b4d.zip
sci-libs/rocSPARSE: lock dev-util/hip version, as with hip-6.0 build fails with "no member named 'gcnArch'"
Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/rocSPARSE/rocSPARSE-5.7.1-r2.ebuild (renamed from sci-libs/rocSPARSE/rocSPARSE-5.7.1-r1.ebuild)8
1 files changed, 5 insertions, 3 deletions
diff --git a/sci-libs/rocSPARSE/rocSPARSE-5.7.1-r1.ebuild b/sci-libs/rocSPARSE/rocSPARSE-5.7.1-r2.ebuild
index d9b2859cad9c..e370820ce9dc 100644
--- a/sci-libs/rocSPARSE/rocSPARSE-5.7.1-r1.ebuild
+++ b/sci-libs/rocSPARSE/rocSPARSE-5.7.1-r2.ebuild
@@ -45,7 +45,7 @@ IUSE="benchmark test"
REQUIRED_USE="${ROCM_REQUIRED_USE}"
SLOT="0/$(ver_cut 1-2)"
-RDEPEND="dev-util/hip
+RDEPEND="=dev-util/hip-5*
sci-libs/rocPRIM:${SLOT}"
DEPEND="${RDEPEND}"
BDEPEND="test? (
@@ -83,11 +83,13 @@ src_prepare() {
sed -i -e "s.set(CMAKE_INSTALL_LIBDIR.#set(CMAKE_INSTALL_LIBDIR." CMakeLists.txt || die
# use python interpreter specifyied by python-any-r1
- sed -e "/COMMAND ..\/common\/rocsparse_gentest.py/s,COMMAND ,COMMAND ${EPYTHON} ," -i clients/tests/CMakeLists.txt || die
+ sed -e "/COMMAND ..\/common\/rocsparse_gentest.py/s,COMMAND ,COMMAND ${EPYTHON} ," \
+ -i clients/tests/CMakeLists.txt || die
cmake_src_prepare
- # Test need download data from https://sparse.tamu.edu (or other mirror site), check MD5, unpack and convert them into csr format
+ # Test need download data from https://sparse.tamu.edu (or other mirror site), check MD5,
+ # unpack and convert them into csr format
# This process is handled default by ${S}/cmake/ClientMatrices.cmake, but should be the responsibility of portage.
if use test; then
mkdir -p "${BUILD_DIR}"/clients/matrices