summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-12-13 06:01:20 +0100
committerSam James <sam@gentoo.org>2022-01-10 01:02:29 +0000
commit62acc9193ee2728e613bb511a483ee16c8947ec1 (patch)
tree8576285e379d9bc881250096dad83d4021b73df4 /sci-libs
parentsci-libs/opencascade: bump to 7.6.0 (diff)
downloadgentoo-62acc9193ee2728e613bb511a483ee16c8947ec1.tar.gz
gentoo-62acc9193ee2728e613bb511a483ee16c8947ec1.tar.bz2
gentoo-62acc9193ee2728e613bb511a483ee16c8947ec1.zip
sci-libs/opencascade: use single slot/subslot for 7.5.2
Instead of using different slots for different versions, the package now uses a single slot with subslots. This is to simplify dependency handling in revdeps. Allow to build against sci-libs/vtk-9.1.0 Package-Manager: Portage-3.0.29, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/opencascade/opencascade-7.5.2-r3.ebuild (renamed from sci-libs/opencascade/opencascade-7.5.2-r2.ebuild)34
1 files changed, 15 insertions, 19 deletions
diff --git a/sci-libs/opencascade/opencascade-7.5.2-r2.ebuild b/sci-libs/opencascade/opencascade-7.5.2-r3.ebuild
index cf90cc0c8aa1..080f7888f0bd 100644
--- a/sci-libs/opencascade/opencascade-7.5.2-r2.ebuild
+++ b/sci-libs/opencascade/opencascade-7.5.2-r3.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://git.dev.opencascade.org/gitweb/?p=occt.git;a=snapshot;h=refs/ta
S="${WORKDIR}/occt-V${MY_PV}"
LICENSE="|| ( Open-CASCADE-LGPL-2.1-Exception-1.0 LGPL-2.1 )"
-SLOT="${PV_MAJ}"
+SLOT="0/${PV_MAJ}"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="debug doc examples ffmpeg freeimage gles2 json optimize tbb vtk"
@@ -25,7 +25,6 @@ REQUIRED_USE="?? ( optimize tbb )"
RESTRICT="test"
RDEPEND="
- app-eselect/eselect-opencascade
dev-lang/tcl:=
dev-lang/tk:=
dev-tcltk/itcl
@@ -49,13 +48,11 @@ RDEPEND="
tbb? ( <dev-cpp/tbb-2021.4.0 )
vtk? ( sci-libs/vtk:=[rendering] )
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+
+BDEPEND="
dev-cpp/eigen
dev-libs/rapidjson
-"
-BDEPEND="
- app-eselect/eselect-opencascade
doc? ( app-doc/doxygen )
examples? ( dev-qt/linguist-tools:5 )
"
@@ -119,7 +116,13 @@ src_configure() {
fi
if use vtk; then
- if has_version ">=sci-libs/vtk-9.0.0"; then
+ if has_version ">=sci-libs/vtk-9.1.0"; then
+ mycmakeargs+=(
+ -D3RDPARTY_VTK_DIR="${ESYSROOT}"/usr
+ -D3RDPARTY_VTK_INCLUDE_DIR="${ESYSROOT}"/usr/include/vtk-9.1
+ -D3RDPARTY_VTK_LIBRARY_DIR="${ESYSROOT}"/usr/$(get_libdir)
+ )
+ elif has_version ">=sci-libs/vtk-9.0.0"; then
mycmakeargs+=(
-D3RDPARTY_VTK_DIR="${ESYSROOT}"/usr
-D3RDPARTY_VTK_INCLUDE_DIR="${ESYSROOT}"/usr/include/vtk-9.0
@@ -134,11 +137,11 @@ src_configure() {
sed -e "s|lib/|$(get_libdir)/|" \
-e "s|VAR_PV|${PV}|" \
-e "s|VAR_CASROOT|${ESYSROOT}/usr|" \
- < "${FILESDIR}"/${PN}-${PV_MAJ}.env.in > "${T}"/${PV_MAJ} || die
+ < "${FILESDIR}"/${PN}.env.in > "${T}"/99${PN} || die
# use TBB for memory allocation optimizations
if use tbb; then
- sed -e 's|^#MMGT_OPT=0$|MMGT_OPT=2|' -i "${T}"/${PV_MAJ} || die
+ sed -e 's|^#MMGT_OPT=0$|MMGT_OPT=2|' -i "${T}"/99${PN} || die
fi
# use internal optimized memory manager and don't clear memory with this
@@ -146,16 +149,14 @@ src_configure() {
if use optimize ; then
sed -e 's|^#MMGT_OPT=0$|MMGT_OPT=1|' \
-e 's|^#MMGT_CLEAR=1$|MMGT_CLEAR=0|' \
- -i "${T}"/${PV_MAJ} || die
+ -i "${T}"/99${PN} || die
fi
}
src_install() {
cmake_src_install
- # respect slotting
- insinto "/etc/env.d/${PN}"
- doins "${T}/${PV_MAJ}"
+ doenvd "${T}/99${PN}"
# remove examples
if use !examples; then
@@ -164,8 +165,3 @@ src_install() {
docompress -x /usr/share/doc/${PF}/overview/html
}
-
-pkg_postinst() {
- eselect ${PN} set ${PV_MAJ} || die "failed to switch to updated implementation"
- einfo "You can switch between available ${PN} implementations using eselect ${PN}"
-}